summaryrefslogtreecommitdiff
path: root/src/gallium/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-12-08 15:26:00 -0800
committerDylan Baker <dylan@pnwbakers.com>2018-01-08 16:39:42 -0800
commit42ea0631f108d82554339530d6c88aa1b448af1e (patch)
tree305e2e7dd00136b80dbaba42e0e1dd104349bd8f /src/gallium/meson.build
parent425fcbde3f816e2a2efb8d1aed2442d40898d447 (diff)
meson: build clover
This has only been compile tested. v2: - Have a single option for opencl (Eric E) - fix typo "tgis" -> "tgsi" (Curro) - Don't add "lib" to pipe loader libraries, which matches the autotools behavior v3: - Remove trailing whitespace - Make PIPE_SEARCH_DIR an absolute path v4: - add trailing / to LIBCLC defines Acked-by: Curro Jerez <currojerez@riseup.net> Tested-by: Jan Vesely <jan.vesely@rutgers.edu> cc: Aaron Watry <awatry@gmail.com> Signed-off-by: Dylan Baker <dylan.c.baker@intel.com>
Diffstat (limited to 'src/gallium/meson.build')
-rw-r--r--src/gallium/meson.build12
1 files changed, 11 insertions, 1 deletions
diff --git a/src/gallium/meson.build b/src/gallium/meson.build
index fc21dcf03e1..6330c7514af 100644
--- a/src/gallium/meson.build
+++ b/src/gallium/meson.build
@@ -145,7 +145,17 @@ endif
if with_gallium_st_nine
subdir('state_trackers/nine')
endif
-# TODO: clover
+if with_gallium_opencl
+ # TODO: this isn't really clover specific, but ATM clover is the only
+ # consumer
+ subdir('targets/pipe-loader')
+
+ if meson.version().version_compare('< 0.44.0')
+ error('OpenCL requires meson 0.44.0 or greater.')
+ endif
+ subdir('state_trackers/clover')
+ subdir('targets/opencl')
+endif
if with_dri
subdir('state_trackers/dri')
subdir('targets/dri')