summaryrefslogtreecommitdiff
path: root/src/gallium/drivers/svga/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2017-10-26 14:19:19 -0700
committerDylan Baker <dylan@pnwbakers.com>2017-11-28 14:06:36 -0800
commita537231b226280bc1e5b7f0f58707cbd2cf29848 (patch)
treeeb1859f98e026156e557137750c48b20629d408a /src/gallium/drivers/svga/meson.build
parent5060c51b6f4dfb0d5358bde6523285163d3faaad (diff)
meson: build svga driver on linux
Build tested only. Signed-off-by: Dylan Baker <dylanx.c.baker@intel.com> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'src/gallium/drivers/svga/meson.build')
-rw-r--r--src/gallium/drivers/svga/meson.build88
1 files changed, 88 insertions, 0 deletions
diff --git a/src/gallium/drivers/svga/meson.build b/src/gallium/drivers/svga/meson.build
new file mode 100644
index 00000000000..d9a7da95a33
--- /dev/null
+++ b/src/gallium/drivers/svga/meson.build
@@ -0,0 +1,88 @@
+# Copyright © 2017 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+files_svga = files(
+ 'svga_cmd.c',
+ 'svga_cmd_vgpu10.c',
+ 'svga_context.c',
+ 'svga_draw_arrays.c',
+ 'svga_draw.c',
+ 'svga_draw_elements.c',
+ 'svga_format.c',
+ 'svga_link.c',
+ 'svga_msg.c',
+ 'svga_pipe_blend.c',
+ 'svga_pipe_blit.c',
+ 'svga_pipe_clear.c',
+ 'svga_pipe_constants.c',
+ 'svga_pipe_depthstencil.c',
+ 'svga_pipe_draw.c',
+ 'svga_pipe_flush.c',
+ 'svga_pipe_fs.c',
+ 'svga_pipe_gs.c',
+ 'svga_pipe_misc.c',
+ 'svga_pipe_query.c',
+ 'svga_pipe_rasterizer.c',
+ 'svga_pipe_sampler.c',
+ 'svga_pipe_streamout.c',
+ 'svga_pipe_vertex.c',
+ 'svga_pipe_vs.c',
+ 'svga_resource_buffer.c',
+ 'svga_resource_buffer_upload.c',
+ 'svga_resource.c',
+ 'svga_resource_texture.c',
+ 'svga_sampler_view.c',
+ 'svga_screen.c',
+ 'svga_screen_cache.c',
+ 'svga_shader.c',
+ 'svga_state.c',
+ 'svga_state_constants.c',
+ 'svga_state_framebuffer.c',
+ 'svga_state_fs.c',
+ 'svga_state_gs.c',
+ 'svga_state_need_swtnl.c',
+ 'svga_state_rss.c',
+ 'svga_state_sampler.c',
+ 'svga_state_tgsi_transform.c',
+ 'svga_state_tss.c',
+ 'svga_state_vdecl.c',
+ 'svga_state_vs.c',
+ 'svga_surface.c',
+ 'svga_swtnl_backend.c',
+ 'svga_swtnl_draw.c',
+ 'svga_swtnl_state.c',
+ 'svga_tgsi.c',
+ 'svga_tgsi_decl_sm30.c',
+ 'svga_tgsi_insn.c',
+ 'svga_tgsi_vgpu10.c',
+ 'svgadump/svga_dump.c',
+ 'svgadump/svga_shader_dump.c',
+ 'svgadump/svga_shader_op.c',
+)
+
+libsvga = static_library(
+ 'svga',
+ files_svga,
+ c_args : [c_vis_args, c_msvc_compat_args],
+ include_directories : [
+ inc_src, inc_include, inc_gallium, inc_gallium_aux,
+ include_directories('include')
+ ],
+)