summaryrefslogtreecommitdiff
path: root/src/gallium/drivers/radeon/Makefile.am
diff options
context:
space:
mode:
authorTom Stellard <thomas.stellard@amd.com>2013-01-11 17:27:45 +0000
committerTom Stellard <thomas.stellard@amd.com>2013-01-11 21:40:42 +0000
commit4fc11fa3c8382635000989ea6563d2f68a64809d (patch)
treea0aef09633452b2adc09ba73f6586102f56ee221 /src/gallium/drivers/radeon/Makefile.am
parent93d5fe14789a1b29ac65ec0afaf61a937d26394b (diff)
drivers/radeon: Don't link against libgallium.la
This fixes several duplicate symbol errors. libllvmradeon is a simple helper library. If it requires symbols in other libraries, this should be taken care of by the gallium target that uses it (e.g. libr600.la)
Diffstat (limited to 'src/gallium/drivers/radeon/Makefile.am')
-rw-r--r--src/gallium/drivers/radeon/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/src/gallium/drivers/radeon/Makefile.am b/src/gallium/drivers/radeon/Makefile.am
index 091adc4016d..e6eb2419d86 100644
--- a/src/gallium/drivers/radeon/Makefile.am
+++ b/src/gallium/drivers/radeon/Makefile.am
@@ -4,7 +4,7 @@ include $(top_srcdir)/src/gallium/Automake.inc
if HAVE_GALLIUM_R600
if HAVE_GALLIUM_RADEONSI
lib_LTLIBRARIES = libllvmradeon@VERSION@.la
-libllvmradeon@VERSION@_la_LDFLAGS = -Wl,--no-undefined -shared -avoid-version \
+libllvmradeon@VERSION@_la_LDFLAGS = -Wl, -shared -avoid-version \
$(LLVM_LDFLAGS)
else
noinst_LTLIBRARIES = libllvmradeon@VERSION@.la
@@ -26,6 +26,5 @@ libllvmradeon@VERSION@_la_SOURCES = \
$(C_FILES)
libllvmradeon@VERSION@_la_LIBADD = \
- $(top_builddir)/src/gallium/auxiliary/libgallium.la \
$(CLOCK_LIB) \
$(LLVM_LIBS)