summaryrefslogtreecommitdiff
path: root/src/gallium/Makefile.am
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2014-07-20 23:12:08 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2014-08-13 00:46:54 +0100
commit7af25d17a5956106c5319ba8cd7d947fbab76f6b (patch)
tree8474aaa4912e5a0d1f0b79f2427bcc54e93e0bde /src/gallium/Makefile.am
parenteeb56b6b438e5acc5e90d0981fb455ba90b1e01a (diff)
automake: compact gallium/target/Makefile into gallium/Makefile
Yet another makefile less to worry about. v2: Add state_trackers and targets on a single SUBDIRS line. Requested by Matt. Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'src/gallium/Makefile.am')
-rw-r--r--src/gallium/Makefile.am35
1 files changed, 20 insertions, 15 deletions
diff --git a/src/gallium/Makefile.am b/src/gallium/Makefile.am
index ceb38b7943c..d35e117578c 100644
--- a/src/gallium/Makefile.am
+++ b/src/gallium/Makefile.am
@@ -105,49 +105,54 @@ endif
##
-## Gallium state trackers
+## Gallium state trackers and their users (targets)
##
+if NEED_GALLIUM_LOADER
+SUBDIRS += targets/pipe-loader
+endif
+
if HAVE_CLOVER
-SUBDIRS += state_trackers/clover
+SUBDIRS += state_trackers/clover targets/opencl
endif
if HAVE_DRICOMMON
-SUBDIRS += state_trackers/dri
+SUBDIRS += state_trackers/dri targets/dri
+endif
+
+## the egl target depends on vega
+if HAVE_OPENVG
+SUBDIRS += state_trackers/vega
endif
if HAVE_GALLIUM_EGL
-SUBDIRS += state_trackers/egl
+SUBDIRS += state_trackers/egl targets/egl-static
endif
if HAVE_GALLIUM_GBM
-SUBDIRS += state_trackers/gbm
+SUBDIRS += state_trackers/gbm targets/gbm
endif
if HAVE_X11_DRIVER
-SUBDIRS += state_trackers/glx/xlib
+SUBDIRS += state_trackers/glx/xlib targets/libgl-xlib
endif
if HAVE_ST_OMX
-SUBDIRS += state_trackers/omx
+SUBDIRS += state_trackers/omx targets/omx
endif
if HAVE_GALLIUM_OSMESA
-SUBDIRS += state_trackers/osmesa
+SUBDIRS += state_trackers/osmesa targets/osmesa
endif
if HAVE_ST_VDPAU
-SUBDIRS += state_trackers/vdpau
-endif
-
-if HAVE_OPENVG
-SUBDIRS += state_trackers/vega
+SUBDIRS += state_trackers/vdpau targets/vdpau
endif
if HAVE_ST_XA
-SUBDIRS += state_trackers/xa
+SUBDIRS += state_trackers/xa targets/xa
endif
if HAVE_ST_XVMC
-SUBDIRS += state_trackers/xvmc
+SUBDIRS += state_trackers/xvmc targets/xvmc
endif