summaryrefslogtreecommitdiff
path: root/src/egl/main
diff options
context:
space:
mode:
authorIan Romanick <ian.d.romanick@intel.com>2012-07-19 16:12:13 -0700
committerIan Romanick <ian.d.romanick@intel.com>2012-08-14 15:41:03 -0700
commitdbecb413008c19e1864de93d9a8a9123bfee46e7 (patch)
tree3d46c86c2f417e10aa03d4af0192f699b441e858 /src/egl/main
parenta2ce2eba26639327d6080fbf3dd64d4ff5ac3bcb (diff)
egl: Allow OpenGL ES 3.0 as a version
In the DRI2 back-end this will get the same API as GLES 2.0. Signed-off-by: Ian Romanick <ian.d.romanick@intel.com> Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>
Diffstat (limited to 'src/egl/main')
-rw-r--r--src/egl/main/eglcontext.c8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/egl/main/eglcontext.c b/src/egl/main/eglcontext.c
index cb50de7a9a7..829050d1475 100644
--- a/src/egl/main/eglcontext.c
+++ b/src/egl/main/eglcontext.c
@@ -54,6 +54,7 @@ _eglGetContextAPIBit(_EGLContext *ctx)
bit = EGL_OPENGL_ES_BIT;
break;
case 2:
+ case 3:
bit = EGL_OPENGL_ES2_BIT;
break;
default:
@@ -317,9 +318,14 @@ _eglParseContextAttribList(_EGLContext *ctx, _EGLDisplay *dpy,
break;
case 2:
+ if (ctx->ClientMinorVersion > 0)
+ err = EGL_BAD_MATCH;
+ break;
+
+ case 3:
default:
/* Don't put additional version checks here. We don't know that
- * there won't be versions > 2.0.
+ * there won't be versions > 3.0.
*/
break;
}