summaryrefslogtreecommitdiff
path: root/src/egl/drivers/glx/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2012-02-06 12:12:53 +0100
committerEric Anholt <eric@anholt.net>2012-02-29 11:52:41 -0800
commite5f895485e03ac60efcb3f6f83ec1d3e33ef7ec2 (patch)
treefb02eb9d6be5c5408bf170bb9d4ff44ada293941 /src/egl/drivers/glx/Makefile.am
parent88612029f6ce9d2717220a0ef31bfe71a8c85529 (diff)
egl/drivers: Convert to automake.
Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>
Diffstat (limited to 'src/egl/drivers/glx/Makefile.am')
-rw-r--r--src/egl/drivers/glx/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/src/egl/drivers/glx/Makefile.am b/src/egl/drivers/glx/Makefile.am
new file mode 100644
index 00000000000..6bf67eaebbe
--- /dev/null
+++ b/src/egl/drivers/glx/Makefile.am
@@ -0,0 +1,33 @@
+# Copyright © 2012 Intel Corporation
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
+# IN THE SOFTWARE.
+
+AM_CFLAGS = \
+ -I$(top_srcdir)/include \
+ -I$(top_srcdir)/src/egl/main \
+ $(X11_CFLAGS) \
+ $(DEFINES)
+
+noinst_LTLIBRARIES = libegl_glx.la
+
+libegl_glx_la_SOURCES = egl_glx.c
+
+libegl_glx_la_LIBADD = \
+ $(EGL_LIB_DEPS)