summaryrefslogtreecommitdiff
path: root/src/egl/Makefile.am
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2018-11-07 13:07:09 +0000
committerEric Engestrom <eric.engestrom@intel.com>2019-01-13 13:59:08 +0000
commitbdf6a5c1d2e01aed88a338c403f28a4b9898068e (patch)
treef7696ecacb43e577328a1bbce65cdfc703b5f83b /src/egl/Makefile.am
parentb938d5fbefe09c67318e88eb869cab016fc6749b (diff)
egl: fix python lib deprecation warning
DeprecationWarning: the imp module is deprecated in favour of importlib Instead of complicated logic, just import the file directly. Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Jordan Justen <jordan.l.justen@intel.com>
Diffstat (limited to 'src/egl/Makefile.am')
-rw-r--r--src/egl/Makefile.am2
1 files changed, 0 insertions, 2 deletions
diff --git a/src/egl/Makefile.am b/src/egl/Makefile.am
index 7269912d96f..ff928525e6c 100644
--- a/src/egl/Makefile.am
+++ b/src/egl/Makefile.am
@@ -143,13 +143,11 @@ GLVND_GEN_DEPS = generate/gen_egl_dispatch.py \
PYTHON_GEN = $(AM_V_GEN)$(PYTHON) $(PYTHON_FLAGS)
g_egldispatchstubs.c: $(GLVND_GEN_DEPS)
$(PYTHON_GEN) $(top_srcdir)/src/egl/generate/gen_egl_dispatch.py source \
- $(top_srcdir)/src/egl/generate/eglFunctionList.py \
$(top_srcdir)/src/egl/generate/egl.xml \
$(top_srcdir)/src/egl/generate/egl_other.xml > $@
g_egldispatchstubs.h: $(GLVND_GEN_DEPS)
$(PYTHON_GEN) $(top_srcdir)/src/egl/generate/gen_egl_dispatch.py header \
- $(top_srcdir)/src/egl/generate/eglFunctionList.py \
$(top_srcdir)/src/egl/generate/egl.xml \
$(top_srcdir)/src/egl/generate/egl_other.xml > $@