summaryrefslogtreecommitdiff
path: root/src/compiler/glsl/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-10-05 09:37:32 -0700
committerDylan Baker <dylan@pnwbakers.com>2018-10-09 08:56:00 -0700
commitb781688636a42be2120047b868abc9bab823acbf (patch)
tree8d862c26ceedde3d76452fd9275b787b9fc9e429 /src/compiler/glsl/meson.build
parentd84f003b9532b0e9386be6caabaf5bfc91645d69 (diff)
meson: Don't build glsl compiler tests unless OpenGL is enabled
Since there are no other users of the glsl compiler. Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'src/compiler/glsl/meson.build')
-rw-r--r--src/compiler/glsl/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/compiler/glsl/meson.build b/src/compiler/glsl/meson.build
index 7e4dd2929a3..71b4c42e4d7 100644
--- a/src/compiler/glsl/meson.build
+++ b/src/compiler/glsl/meson.build
@@ -258,6 +258,6 @@ glsl_test = executable(
install : with_tools.contains('glsl'),
)
-if with_tests
+if with_any_opengl and with_tests
subdir('tests')
endif