summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-06-25 15:44:16 +0100
committerMarge Bot <eric+marge@anholt.net>2020-07-10 13:48:24 +0000
commite00adef34a5ce485e2c9216a268ca05e89a5fc98 (patch)
tree9a0c50ebf87be3d744f80878c9224e067dc5c0c6 /meson.build
parent60ad006b27e1e577e29636e56178523893051968 (diff)
egl: automatically compile the `drm` platform when available
Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Emil Velikov <emil.velikov@collabora.com> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/3161>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 10 insertions, 7 deletions
diff --git a/meson.build b/meson.build
index c9b4e366ea3..faa267978bf 100644
--- a/meson.build
+++ b/meson.build
@@ -293,7 +293,7 @@ endif
_platforms = get_option('platforms')
if _platforms.contains('auto')
if system_has_kms_drm
- _platforms = ['x11', 'wayland', 'drm']
+ _platforms = ['x11', 'wayland']
elif ['darwin', 'cygwin'].contains(host_machine.system())
_platforms = ['x11']
elif ['haiku'].contains(host_machine.system())
@@ -309,7 +309,6 @@ endif
with_platform_android = _platforms.contains('android')
with_platform_x11 = _platforms.contains('x11')
with_platform_wayland = _platforms.contains('wayland')
-with_platform_drm = _platforms.contains('drm')
with_platform_haiku = _platforms.contains('haiku')
with_platform_windows = _platforms.contains('windows')
@@ -317,6 +316,10 @@ if _platforms.contains('surfaceless')
warning('Platform `surfaceless` is now always selected; setting this option will be an error in Mesa 20.3')
endif
+if _platforms.contains('drm')
+ warning('Platform `drm` is now automatically selected; setting this option will be an error in Mesa 20.3')
+endif
+
if _platforms.length() != 0
egl_native_platform = _platforms[0]
else
@@ -382,7 +385,7 @@ elif _xlib_lease == 'false'
warning('xlib_lease option "false" deprecated, please use "disabled" instead.')
endif
if _xlib_lease == 'auto'
- with_xlib_lease = with_platform_x11 and with_platform_drm
+ with_xlib_lease = with_platform_x11 and with_gbm
else
with_xlib_lease = _xlib_lease == 'enabled'
endif
@@ -822,10 +825,7 @@ else
pre_args += '-DEGL_NO_X11'
gl_pkgconfig_c_flags += '-DEGL_NO_X11'
endif
-if with_platform_drm
- if with_egl and not with_gbm
- error('EGL drm platform requires gbm')
- endif
+if with_gbm
pre_args += '-DHAVE_DRM_PLATFORM'
endif
if with_platform_android
@@ -1881,6 +1881,9 @@ endif
lines += 'GBM: ' + (with_gbm ? 'yes' : 'no')
if with_egl or with_any_vk
_platforms += 'surfaceless'
+ if with_gbm
+ _platforms += 'drm'
+ endif
lines += 'EGL/Vulkan/VL platforms: ' + ' '.join(_platforms)
endif