summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@intel.com>2019-09-23 18:53:22 +0100
committerEric Engestrom <eric.engestrom@intel.com>2019-09-24 19:39:24 +0100
commitda496d4e30b78a0a8e096453f3ffccffaf9c2f7e (patch)
tree453e0e560d718f61e5340c2e5e6cc03a4cb4de04 /meson.build
parent3fd0afd5e3f7d2c5b8b5bfb77a111decfb193240 (diff)
meson: split more compiler options to their own line
Signed-off-by: Eric Engestrom <eric.engestrom@intel.com> Reviewed-by: Dylan Baker <dylan@pnwbakers.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 4 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index ce0eb154edc..4a80d6a55ad 100644
--- a/meson.build
+++ b/meson.build
@@ -896,7 +896,8 @@ foreach a : ['-Werror=implicit-function-declaration',
'-Wno-missing-field-initializers',
'-Wno-format-truncation',
'-fno-math-errno',
- '-fno-trapping-math', '-Qunused-arguments']
+ '-fno-trapping-math',
+ '-Qunused-arguments']
if cc.has_argument(a)
c_args += a
endif
@@ -915,7 +916,8 @@ foreach a : ['-Werror=return-type',
'-Wno-non-virtual-dtor',
'-Wno-missing-field-initializers',
'-Wno-format-truncation',
- '-fno-math-errno', '-fno-trapping-math',
+ '-fno-math-errno',
+ '-fno-trapping-math',
'-Qunused-arguments']
if cpp.has_argument(a)
cpp_args += a