summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-04-18 13:01:09 -0700
committerDylan Baker <dylan@pnwbakers.com>2019-09-10 20:36:47 +0000
commitb9fa7ec4fa05f51968421b19f9408114f3586342 (patch)
tree7bd2cb6622c6b1f839f70f10d904fe3192cf0706 /meson.build
parent8ba86ad55c5a0a5a6c4ed25443d06442caa5072d (diff)
meson: add a expat subproject
For Windows Reviewed-by: Eric Anholt <eric@anholt.net> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 4be5845f2d6..65afcb4ec60 100644
--- a/meson.build
+++ b/meson.build
@@ -1158,7 +1158,7 @@ if dep_thread.found() and host_machine.system() != 'windows'
pre_args += '-DPTHREAD_SETAFFINITY_IN_NP_HEADER'
endif
endif
-dep_expat = dependency('expat')
+dep_expat = dependency('expat', fallback : ['expat', 'expat_dep'])
# this only exists on linux so either this is linux and it will be found, or
# it's not linux and wont
dep_m = cc.find_library('m', required : false)