summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2017-04-21 21:57:50 -0700
committerEric Engestrom <eric.engestrom@intel.com>2019-10-16 13:45:57 +0100
commitb3028a9fb8110fd37f60e9d66dad3cde6e7b062b (patch)
tree357c26fd3de0e90f9d917e6700bc00a15f4041d7 /meson.build
parenta56c3e3a470eb8f13d11ca0aad5b5934de54ca1c (diff)
util: Workaround lack of flock on Solaris
v2: Replace autoconf check for flock() with meson check Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com> Acked-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c96f1ed0f7b..e1ca9559b56 100644
--- a/meson.build
+++ b/meson.build
@@ -1144,7 +1144,7 @@ foreach h : ['xlocale.h', 'sys/sysctl.h', 'linux/futex.h', 'endian.h', 'dlfcn.h'
endif
endforeach
-foreach f : ['strtof', 'mkostemp', 'timespec_get', 'memfd_create', 'random_r']
+foreach f : ['strtof', 'mkostemp', 'timespec_get', 'memfd_create', 'random_r', 'flock']
if cc.has_function(f)
pre_args += '-DHAVE_@0@'.format(f.to_upper())
endif