summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric@engestrom.ch>2020-08-01 13:41:30 +0200
committerMarge Bot <eric+marge@anholt.net>2020-08-02 16:23:47 +0000
commita4181fcd422ddd2a58467eda338847db7c14efd1 (patch)
tree618b7b130083a3a36fb02575602e966002547c7a /meson.build
parentc1476044b5525994cc317c81a5cb9da60d58755d (diff)
meson: fix `-D xlib-lease=auto` detection
This is used by Vulkan, not EGL, and depends on having DRM/KMS, not GBM. Reported-by: Oschowa <oschowa@web.de> Closes: https://gitlab.freedesktop.org/mesa/mesa/-/issues/3346 Fixes: e00adef34a5ce485e2c9 ("egl: automatically compile the `drm` platform when available") Signed-off-by: Eric Engestrom <eric@engestrom.ch> Reviewed-by: Bas Nieuwenhuizen <bas@basnieuwenhuizen.nl> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/6150>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 011b1eca832..4b57cf326ec 100644
--- a/meson.build
+++ b/meson.build
@@ -389,7 +389,7 @@ elif _xlib_lease == 'false'
warning('xlib_lease option "false" deprecated, please use "disabled" instead.')
endif
if _xlib_lease == 'auto'
- with_xlib_lease = with_platform_x11 and with_gbm
+ with_xlib_lease = with_platform_x11 and system_has_kms_drm
else
with_xlib_lease = _xlib_lease == 'enabled'
endif