summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric@engestrom.ch>2020-02-02 15:29:08 +0000
committerMarge Bot <eric+marge@anholt.net>2020-02-05 23:17:26 +0000
commit9595b23a45a6bcb7ee784e2c38085a8ea2e4620a (patch)
tree9288dd1c9c6ef9025d841377924a7cdb290da7b8 /meson.build
parent4d34abd15c91ed67414e2e0dc1ae252f53574ef6 (diff)
meson: don't bother trying `python2`
Meson requires `python3`, so we know it's there, no need to fall back to python2. Signed-off-by: Eric Engestrom <eric@engestrom.ch> Reviewed-by: Dylan Baker <dylan@pnwbakers.com> Tested-by: Marge Bot <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3701> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/merge_requests/3701>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index c48945b3c48..9d9f3031e90 100644
--- a/meson.build
+++ b/meson.build
@@ -22,7 +22,7 @@ project(
'mesa',
['c', 'cpp'],
version : run_command(
- [find_program('python', 'python2', 'python3'), 'bin/meson_get_version.py']
+ [find_program('python', 'python3'), 'bin/meson_get_version.py']
).stdout(),
license : 'MIT',
meson_version : '>= 0.46',