summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2019-05-09 10:32:31 -0700
committerDylan Baker <dylan@pnwbakers.com>2019-09-30 18:06:56 +0000
commit3b265f61f5f61f08718fe5bb4b2726f9b8e016cc (patch)
treeb944fca49342dda93b0283e7bd4f0602167885fc /meson.build
parenta0a93763fba18ce3c9c90a0f939005f0b594e27c (diff)
meson: gallium media state trackers require libdrm with x11
v2: - update copyright year in all changed files - rebase on master Cc: 19.1 19.2 <mesa-stable@lists.freedesktop.org> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index aea5c2e4444..9fe017d5455 100644
--- a/meson.build
+++ b/meson.build
@@ -1445,6 +1445,9 @@ if with_platform_x11
with_gallium_omx != 'disabled'))
dep_xcb = dependency('xcb')
dep_x11_xcb = dependency('x11-xcb')
+ if not dep_libdrm.found()
+ error('libdrm required for gallium video statetrackers when using x11')
+ endif
endif
if with_any_vk or with_egl or (with_glx == 'dri' and with_dri_platform == 'drm')
dep_xcb_dri2 = dependency('xcb-dri2', version : '>= 1.8')