summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-04-18 13:19:20 -0700
committerDylan Baker <dylan@pnwbakers.com>2019-09-10 20:36:47 +0000
commit304719993120c463e14de40cbe0297e645142881 (patch)
tree722faaf721f2469e3713bf5b4c9075d3068313e0 /meson.build
parente1e2388f06df1c9ab145c99d8f0f6cea22815528 (diff)
meson: don't allow glvnd on windows
Reviewed-by: Eric Anholt <eric@anholt.net> Reviewed-by: Eric Engestrom <eric.engestrom@intel.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 26c1b0bb376..f268c81b44b 100644
--- a/meson.build
+++ b/meson.build
@@ -418,7 +418,9 @@ endif
with_glvnd = get_option('glvnd')
if with_glvnd
- if with_glx == 'xlib' or with_glx == 'gallium-xlib'
+ if with_platform_windows
+ error('glvnd cannot be used on Windows')
+ elif with_glx == 'xlib' or with_glx == 'gallium-xlib'
error('Cannot build glvnd support for GLX that is not DRI based.')
elif with_glx == 'disabled' and not with_egl
error('glvnd requires DRI based GLX and/or EGL')