summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDaniel Stone <daniels@collabora.com>2020-01-28 12:47:20 +0000
committerErik Faye-Lund <erik.faye-lund@collabora.com>2020-03-30 10:13:40 +0000
commit04885d61dd228f3da6f88584d3eb1d7e4c228e98 (patch)
treebe7a6cf0792a7a851223e444a3e3710dd82bea26 /meson.build
parent5127160fb61927c40117f80c3abd291f9d3fa98a (diff)
meson: Add VS 4624 warning exclusion to remove piles of LLVM warnings
Reviewed-by: Jose Fonseca <jfonseca@vmware.com> Reviewed-by: Charmaine Lee <charmainel@vmware.com> Reviewed-by: Brian Paul <brianp@vmware.com> Tested-by: Marge Bot <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4343> Part-of: <https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/4343>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 3 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index 45a760c7d02..86824bd8e8b 100644
--- a/meson.build
+++ b/meson.build
@@ -935,7 +935,9 @@ if cc.get_id() == 'msvc'
'/wd4996', # disabled deprecated POSIX name warnings
'/wd4291', # no matching operator delete found
'/wd4146', # unary minus operator applied to unsigned type, result still unsigned
- '/wd4200'] # nonstandard extension used: zero-sized array in struct/union
+ '/wd4200', # nonstandard extension used: zero-sized array in struct/union
+ '/wd4624', # destructor was implicitly defined as deleted [from LLVM]
+ ]
if cc.has_argument(a)
c_args += a
endif