summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorDylan Baker <dylan@pnwbakers.com>2018-10-22 07:26:44 -0700
committerDylan Baker <dylan@pnwbakers.com>2018-10-22 11:29:55 -0700
commit4e785fb383eaa80e7def0d639eddefb781ec3f4f (patch)
tree8b3f3db534f17815ee24998a4d200e26ae01d6ff /meson.build
parentca4e465f7d018f8702ddb5332bf1c892b1808366 (diff)
meson: don't require libelf for r600 without LLVM
r600 doesn't have a hard requirement on LLVM, and therefore doesn't have a hard requirement on libelf. Currently the logic doesn't allow that however. Distro-bug: https://bugs.gentoo.org/669058 Fixes: 5060c51b6f4dfb0d5358bde6523285163d3faaad ("meson: build r600 driver") Reviewed-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build18
1 files changed, 10 insertions, 8 deletions
diff --git a/meson.build b/meson.build
index 0dfe09858bf..712210f0f1b 100644
--- a/meson.build
+++ b/meson.build
@@ -1086,14 +1086,6 @@ if dep_thread.found() and host_machine.system() != 'windows'
pre_args += '-DHAVE_PTHREAD_SETAFFINITY'
endif
endif
-if with_amd_vk or with_gallium_radeonsi or with_gallium_r600 or with_gallium_opencl
- dep_elf = dependency('libelf', required : false)
- if not dep_elf.found()
- dep_elf = cc.find_library('elf')
- endif
-else
- dep_elf = null_dep
-endif
dep_expat = dependency('expat')
# this only exists on linux so either this is linux and it will be found, or
# its not linux and and wont
@@ -1240,6 +1232,16 @@ elif with_amd_vk or with_gallium_radeonsi or with_gallium_swr
error('The following drivers require LLVM: Radv, RadeonSI, SWR. One of these is enabled, but LLVM is disabled.')
endif
+if (with_amd_vk or with_gallium_radeonsi or with_gallium_opencl or
+ (with_gallium_r600 and with_llvm))
+ dep_elf = dependency('libelf', required : false)
+ if not dep_elf.found()
+ dep_elf = cc.find_library('elf')
+ endif
+else
+ dep_elf = null_dep
+endif
+
dep_glvnd = null_dep
if with_glvnd
dep_glvnd = dependency('libglvnd', version : '>= 0.2.0')