summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2014-03-12 00:36:21 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2014-03-31 12:18:39 +0100
commite8e1158ac35d21a16b47ada09a6dc5fa9d7764d8 (patch)
treec47293c513d81c599b74ae3b20a0a68086e7b98b /configure.ac
parent4d8267ef209f29cbfe0075500083a2721a9aa885 (diff)
configure: error out when building gallium-osmesa without softpipe
Gallium osmesa links against the softpipe driver, thus the build will fail if it's missing. Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Acked-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cad4b05242a..03c1d312048 100644
--- a/configure.ac
+++ b/configure.ac
@@ -762,8 +762,8 @@ if test "x$enable_dri" = xyes; then
fi
if test "x$enable_gallium_osmesa" = xyes; then
- if test -z "$with_gallium_drivers"; then
- AC_MSG_ERROR([Cannot enable gallium_osmesa without Gallium])
+ if ! echo "$with_gallium_drivers" | grep -q 'swrast'; then
+ AC_MSG_ERROR([gallium_osmesa requires the gallium swrast driver])
fi
if test "x$enable_osmesa" = xyes; then
AC_MSG_ERROR([Cannot enable both classic and Gallium OSMesa implementations])