summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2008-05-05 14:38:22 -0700
committerDan Nicholson <dbn.lists@gmail.com>2008-05-05 15:45:20 -0700
commitcc77e8f1131fc66e8405dc4d3b03582db1f54ca4 (patch)
tree270dab076bc7a00939fd417b43b8b03502e98bf2 /configure.ac
parent297e16cc7acc45b7946e03febd370ecba7835750 (diff)
autoconf: Error for incompatible version of libdrm
The DRI modules can only be built against libdrm master (currently version 2.3.1), so this should be enforced to save people from trying to build against older versions. Added a section at the top of the script to consolidate all required versions.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index ca63c7e20af..bc2ebf6583f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,6 +17,10 @@ AC_INIT([Mesa],[mesa_version],
AC_CONFIG_AUX_DIR([bin])
AC_CANONICAL_HOST
+dnl Versions for external dependencies
+LIBDRM_REQUIRED=2.3.1
+DRI2PROTO_REQUIRED=1.1
+
dnl Check for progs
AC_PROG_CPP
AC_PROG_CC
@@ -404,8 +408,8 @@ dri)
fi
# Check for libdrm
- PKG_CHECK_MODULES([LIBDRM], [libdrm])
- PKG_CHECK_MODULES([DRI2PROTO], [dri2proto >= 1.1])
+ PKG_CHECK_MODULES([LIBDRM], [libdrm >= $LIBDRM_REQUIRED])
+ PKG_CHECK_MODULES([DRI2PROTO], [dri2proto >= $DRI2PROTO_REQUIRED])
# find the DRI deps for libGL
if test "$x11_pkgconfig" = yes; then