summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olvaffe@gmail.com>2011-11-05 15:09:36 +0800
committerChia-I Wu <olvaffe@gmail.com>2011-11-05 15:15:21 +0800
commit95ef069e1cc2a98a77ea14d63ff1769beeb67c14 (patch)
treed4c0ef4437ad14c4ba7730bf4c4140e764ea2bd9 /configure.ac
parent0c771e260b20de06aa0a9671130119304e9fe0db (diff)
configure.ac: gbm_gallium requires DRI_LIB_DEPS to link
gbm_gallium does not depend on DRI, but its build rules depend on DRI_LIB_DEPS being set. Output an error when the user enables gbm_gallium but disables DRI. This is just a workaround.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 707acf3cf45..8885a6d74e5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1427,8 +1427,8 @@ dnl
dnl gbm Gallium configuration
dnl
if test "x$enable_gallium_gbm" = xauto; then
- case "$enable_gbm$HAVE_ST_EGL$with_egl_platforms" in
- yesyes*drm*)
+ case "$enable_gbm$HAVE_ST_EGL$enable_dri$with_egl_platforms" in
+ yesyesyes*drm*)
enable_gallium_gbm=yes ;;
*)
enable_gallium_gbm=no ;;
@@ -1441,6 +1441,10 @@ if test "x$enable_gallium_gbm" = xyes; then
if test "x$enable_gbm" = xno; then
AC_MSG_ERROR([cannot enable gbm_gallium without gbm])
fi
+ # gbm_gallium abuses DRI_LIB_DEPS to link. Make sure it is set.
+ if test "x$enable_dri" = xno; then
+ AC_MSG_ERROR([gbm_gallium requires --enable-dri to build])
+ fi
GALLIUM_STATE_TRACKERS_DIRS="gbm $GALLIUM_STATE_TRACKERS_DIRS"
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS gbm"