summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Franzke <benjaminfranzke@googlemail.com>2011-07-02 13:46:42 +0200
committerBenjamin Franzke <benjaminfranzke@googlemail.com>2011-07-02 14:01:07 +0200
commit7ed1826e2e2a5b5c4840821c92ef7273efe32e24 (patch)
tree23655ed41e89c2f477736cc046ebb93bff213a42 /configure.ac
parent9b8cd499303d9bcb60f40ef14553cb38cea6a897 (diff)
configure: Require libudev for drm & wayland egl platforms
NOTE: This is a candidate for the 7.11 branch.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 74a511edd2b..7d0f3d8ba5c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1724,6 +1724,10 @@ yes)
if test "$plat" = "drm" && test "x$enable_gbm" = "xno"; then
AC_MSG_ERROR([EGL platform drm needs gbm])
fi
+ case "$plat$have_libudev" in
+ waylandno|drmno)
+ AC_MSG_ERROR([cannot build $plat platfrom without udev]) ;;
+ esac
done
EGL_PLATFORMS="$egl_platforms"
;;