summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2008-05-06 06:21:41 -0700
committerDan Nicholson <dbn.lists@gmail.com>2008-05-09 07:06:52 -0700
commit5dbbde5b222204fa8dfc086b88a8105516f7d727 (patch)
tree9dbddd860223643bf436950f9a74a4409c257d44 /configure.ac
parentd368eed9c78aa3ced8540c66bdc4c5e1d4a067b4 (diff)
Default DRI driver directory to match X.Org xserver
Since the only valid consumer of the DRI drivers is the X.Org xserver, this changes the default DRI driver directory to match xorg-server: ${libdir}/dri. The old default of /usr/X11R6/modules/dri was wrong for nearly all current systems.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index e57f7b7de62..86958843661 100644
--- a/configure.ac
+++ b/configure.ac
@@ -443,9 +443,9 @@ AC_ARG_ENABLE([glx-tls],
dnl Directory for DRI drivers
AC_ARG_WITH([dri-driverdir],
[AS_HELP_STRING([--with-dri-driverdir=DIR],
- [directory for the DRI drivers @<:@/usr/X11R6/lib/modules/dri@:>@])],
+ [directory for the DRI drivers @<:@${libdir}/dri@:>@])],
[DRI_DRIVER_INSTALL_DIR="$withval"],
- [DRI_DRIVER_INSTALL_DIR='/usr/X11R6/lib/modules/dri'])
+ [DRI_DRIVER_INSTALL_DIR='${libdir}/dri'])
AC_SUBST([DRI_DRIVER_INSTALL_DIR])
dnl Direct rendering or just indirect rendering
AC_ARG_ENABLE([driglx-direct],