summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olv@lunarg.com>2010-04-26 12:56:44 +0800
committerChia-I Wu <olv@lunarg.com>2010-05-07 10:41:11 +0800
commit296adbd545b8efd38c9ed508166b2de2764a444b (patch)
treeb146a292769007902a0aca98cfdd9d8ce7c44b59 /configure.ac
parent73ded0624de66bc83ae990530febb129d950d04b (diff)
glapi: Move to src/mapi/.
Move glapi to src/mapi/{glapi,es1api,es2api}.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b2e49a71365..4f37e16e3f0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -463,7 +463,7 @@ dnl Driver specific build directories
dnl
dnl this variable will be prepended to SRC_DIRS and is not exported
-CORE_DIRS="glsl mesa"
+CORE_DIRS="mapi/glapi glsl mesa"
SRC_DIRS="glew"
GLU_DIRS="sgi"
@@ -763,6 +763,7 @@ if test "x$enable_gles2" = xyes; then
APIS="$APIS es2"
fi
if test "x$enable_gles1" = xyes -o "x$enable_gles2" = xyes; then
+ CORE_DIRS="mapi/es1api mapi/es2api $CORE_DIRS"
SRC_DIRS="$SRC_DIRS gles"
fi
AC_SUBST([API_DEFINES])
@@ -1308,6 +1309,9 @@ yes)
HAVE_ST_XORG="yes"
;;
es)
+ if test "x$enable_gles1" != xyes -a "x$enable_gles2" != xyes; then
+ CORE_DIRS="mapi/es1api mapi/es2api $CORE_DIRS"
+ fi
# mesa/es is required to build es state tracker
CORE_DIRS="$CORE_DIRS mesa/es"
;;