summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRob Clark <robclark@freedesktop.org>2013-05-26 17:13:44 -0400
committerRob Clark <robclark@freedesktop.org>2013-06-08 13:15:51 -0400
commit2855f3f7bcd9b36a275e942c9c7d0eb8e485c16f (patch)
tree436514501ba4d2ceb907d5eb940181b0ed3704e6 /configure.ac
parent18c317b21ddc2ec4538544f9dd69dc568dcf821f (diff)
freedreno: add a3xx support
The adreno a3xx GPU is found in newer snapdragon devices, such as the nexus4. The a3xx is GLESv3 and OpenCL capable, although that is not enabled yet in gallium. Compared to a2xx, it introduces an entirely new unified shader ISA, and re-shuffles all or nearly all of the registers. The good news is that (for the most part) the registers are more orthogonal, not combining unrelated state in a single register. And that there is a lot more flexibility, so we don't need to patch and re-emit the shader like we did on a2xx. The shader compiler is currently quite dumb, there would be a lot of room for improvement with an optimizing pass. Despite that, with the a320 in my nexus4 it seems to be ~2-3x faster compared to the a220 in my HP touchpad. Signed-off-by: Rob Clark <robclark@freedesktop.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8d4a3dc27b0..6832b0d8973 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1985,6 +1985,7 @@ AC_CONFIG_FILES([Makefile
src/gallium/drivers/Makefile
src/gallium/drivers/freedreno/Makefile
src/gallium/drivers/freedreno/a2xx/Makefile
+ src/gallium/drivers/freedreno/a3xx/Makefile
src/gallium/drivers/i915/Makefile
src/gallium/drivers/ilo/Makefile
src/gallium/drivers/llvmpipe/Makefile