summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2018-02-23 19:32:05 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2018-08-08 13:37:09 +0100
commit25a9450a44b3b572fba81e6cafe33f3367252499 (patch)
tree27fe9e7ca2d654811e94164570f763dbb0ee791f /configure.ac
parentd5ac23647110fd530f9bf5002762587be446866d (diff)
autotools: error out when building with mangling and glvnd
It's not a thing that can work, nor is a wise idea to attempt. v2: Tweak error message (Dylan) CC: <mesa-stable@lists.freedesktop.org> Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Adam Jackson <ajax@redhat.com> (v1)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6b1b8aca753..e2c48a455c2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1524,6 +1524,9 @@ AC_ARG_ENABLE([mangling],
[enable_mangling=no]
)
if test "x${enable_mangling}" = "xyes" ; then
+ if test "x$enable_libglvnd" = xyes; then
+ AC_MSG_ERROR([Conflicting options --enable-mangling and --enable-libglvnd.])
+ fi
DEFINES="${DEFINES} -DUSE_MGL_NAMESPACE"
GL_LIB="Mangled${GL_LIB}"
OSMESA_LIB="Mangled${OSMESA_LIB}"