summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChia-I Wu <olv@lunarg.com>2010-10-31 21:01:54 +0800
committerChia-I Wu <olv@lunarg.com>2010-10-31 21:22:26 +0800
commit1230050363cd30c457a64e51dac41f3471e87fc4 (patch)
tree54ca338bea0c91114249b3960e212d5c8c8614d6 /configure.ac
parenta15cf3cd0b21d593033a3abd2b1788de292001bd (diff)
autoconf: Tidy configure output for EGL.
Prefix EGL driver names by "egl_". Make it clear that EGL_CLIENT_APIS is only used by egl_gallium.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 9 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 53f938c7028..feb8c7fd084 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1758,12 +1758,17 @@ echo ""
echo " EGL: $enable_egl"
if test "$enable_egl" = yes; then
echo " EGL platforms: $EGL_PLATFORMS"
- echo " EGL drivers: $EGL_DRIVERS_DIRS"
+
+ egl_drivers=""
+ for d in $EGL_DRIVERS_DIRS; do
+ egl_drivers="$egl_drivers egl_$d"
+ done
+
if test "$enable_gallium" = yes -a "$HAVE_ST_EGL" = yes; then
- echo " EGL tracker: yes"
- echo " EGL client APIs:$EGL_CLIENT_APIS"
+ echo " EGL drivers: ${egl_drivers} egl_gallium"
+ echo " EGL Gallium STs:$EGL_CLIENT_APIS"
else
- echo " EGL tracker: no"
+ echo " EGL drivers: $egl_drivers"
fi
fi
@@ -1784,9 +1789,6 @@ if echo "$SRC_DIRS" | grep 'gallium' >/dev/null 2>&1; then
echo " Winsys dirs: $GALLIUM_WINSYS_DIRS"
echo " Driver dirs: $GALLIUM_DRIVERS_DIRS"
echo " Trackers dirs: $GALLIUM_STATE_TRACKERS_DIRS"
- if test "x$HAVE_ST_EGL" = xyes; then
- echo " EGL client APIs: $EGL_CLIENT_APIS"
- fi
else
echo " Gallium: no"
fi