summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2008-05-06 11:28:43 -0700
committerDan Nicholson <dbn.lists@gmail.com>2008-05-06 11:28:43 -0700
commite14ebbce41c8acee5f77633c6c536d92f84a5c20 (patch)
treef200f63fa74a174c5b01ddf9676b958bd9637501 /configure.ac
parent17adf04e5c1da72a51815f3fdb9de2f3a8149c1a (diff)
autoconf: Replace the configs/current symlink from config.status
Minor tweak so that running config.status will entirely recreate the configure settings by replacing the configs/current symlink.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b0f17f9286b..cccf7bd44d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -901,13 +901,16 @@ CPPFLAGS="$_SAVE_CPPFLAGS"
dnl Substitute the config
AC_CONFIG_FILES([configs/autoconf])
-AC_OUTPUT
dnl Replace the configs/current symlink
+AC_CONFIG_COMMANDS([configs],[
if test -f configs/current || test -L configs/current; then
rm -f configs/current
fi
ln -s autoconf configs/current
+])
+
+AC_OUTPUT
dnl
dnl Output some configuration info for the user