summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJon TURNEY <jon.turney@dronecode.org.uk>2009-06-08 16:02:18 +0100
committerBrian Paul <brianp@vmware.com>2009-06-08 14:30:46 -0600
commit7eed6ab5b525b75f690d05042c90d05827253114 (patch)
treed56a03f4afd62484382950861f55b6ae8eaf8f4a /configure.ac
parent304ba4bba44057aa21f0ae434e49b1e09ab7d039 (diff)
Cygwin build fixes
Fix mklib to deal with NOPREFIX and use --enable-auto-image-base for cygwin Teach configure.ac some basic facts about cygwin Signed-off-by: Jon TURNEY <jon.turney@dronecode.org.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 48b8022736d..2a9ac1ed9cd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -222,6 +222,8 @@ else
case "$host_os" in
darwin* )
LIB_EXTENSION='dylib' ;;
+ cygwin* )
+ LIB_EXTENSION='dll' ;;
* )
LIB_EXTENSION='so' ;;
esac
@@ -1073,6 +1075,9 @@ if test "x$APP_LIB_DEPS" = x; then
solaris*)
APP_LIB_DEPS="-lX11 -lsocket -lnsl -lm"
;;
+ cygwin*)
+ APP_LIB_DEPS="-lX11"
+ ;;
*)
APP_LIB_DEPS="-lm"
;;