summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2009-01-12 11:10:31 -0800
committerDan Nicholson <dbn.lists@gmail.com>2009-01-12 11:10:31 -0800
commit29f603a270da711a2a980cc9896e5883e59227cd (patch)
tree8899b1e91736e5f79ac94b0409d7f1f6b635a694 /configure.ac
parent7f7fc3e3af6471a224a10bf3d2cd6ddd7a96d334 (diff)
autoconf: Only _GNU_SOURCE feature test macro needed on gnu systems
According to feature_test_macros(7), _GNU_SOURCE encompasses all the other feature macros we were setting, so we can just dispose of them.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 6a99f3031e2..33c107266a2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -84,10 +84,7 @@ DEFINES=""
AC_SUBST([DEFINES])
case "$host_os" in
*-gnu*)
-if test "x$GCC" = xyes; then
- DEFINES="$DEFINES -D_POSIX_SOURCE -D_POSIX_C_SOURCE=199309L -D_BSD_SOURCE"
-fi
- DEFINES="$DEFINES -D_SVID_SOURCE -D_GNU_SOURCE -DPTHREADS"
+ DEFINES="$DEFINES -D_GNU_SOURCE -DPTHREADS"
;;
solaris*)
DEFINES="$DEFINES -DPTHREADS -DSVR4"