summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2008-06-30 09:40:30 -0700
committerDan Nicholson <dbn.lists@gmail.com>2008-07-12 10:25:40 -0700
commitbfb27b5fc020437d95b1185f0fce850209744d92 (patch)
tree098a0facc626f441038af39ff01bc513c4a060f0 /configure.ac
parent2d766923c45b544cca17c7fefe625715cf1fd1fe (diff)
autoconf: Subsitute SHELL for all platforms
Establish the shell that make will use from configure. This is exactly how autoconf/automake operate, with the environment variable CONFIG_SHELL respected to override the autoconf checks. In the usual case where the user just executes `./configure', autoconf will pick a shell from the current shell, sh, bash, ksh or sh5 that meets its base criteria. The special Solaris case of looking for a POSIX shell has been changed to just set the SHELL variable since autoconf substitutes this already. The EXTRA_CONFIG_LINES substitution is dropped as it should no longer be needed.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ec8b5ddbc75..acb29e44686 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,18 +33,16 @@ AC_CHECK_PROGS([MAKE], [gmake make])
AC_PATH_PROG([MKDEP], [makedepend])
AC_PATH_PROG([SED], [sed])
-dnl Platform-specific program settings
-EXTRA_CONFIG_LINES=""
-AC_SUBST([EXTRA_CONFIG_LINES])
+dnl We need a POSIX shell for parts of the build. Assume we have one
+dnl in most cases.
case "$host_os" in
solaris*)
# Solaris /bin/sh is too old/non-POSIX compliant
AC_PATH_PROGS(POSIX_SHELL, [ksh93 ksh sh])
- EXTRA_CONFIG_LINES="SHELL=$POSIX_SHELL"
+ SHELL="$POSIX_SHELL"
;;
esac
-
MKDEP_OPTIONS=-fdepend
dnl Ask gcc where it's keeping its secret headers
if test "x$GCC" = xyes; then