summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMike Stroyan <mike@LunarG.com>2013-03-18 13:34:35 -0600
committerAndreas Boll <andreas.boll.dev@gmail.com>2013-06-06 08:54:07 +0200
commit962204961def009610e60b23d40a22f064214dc7 (patch)
tree8979e5b50b735d6e69dc0faa5703f0f5341561c4 /configure.ac
parentce67fb4715e0c2fab01de33da475ef4705622020 (diff)
configure.ac: Build dricommon for gallium swrast
When building dri-swrast, use gallium_check_st to set HAVE_COMMON_DRI. Commit 07f2dee7 added setting of HAVE_COMMON_DRI in gallium_check_st. But the dri-swrast case did not use gallium_check_st. So dri/common was still not built. v2: set HAVE_COMMON_DRI=yes instead of using gallium_check_st NOTE: This is a candidate for the 9.1 branch. (Depends on 7de78ce5 and 07f2dee) Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=61821 Signed-off-by: Andreas Boll <andreas.boll.dev@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 521331bb4d1..bccab0aa1f6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1812,6 +1812,7 @@ if test "x$with_gallium_drivers" != x; then
if test "x$enable_dri" = xyes; then
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS dri-swrast"
+ HAVE_COMMON_DRI=yes
fi
if test "x$enable_vdpau" = xyes; then
GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS vdpau-softpipe"