summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2015-07-31 12:18:37 -0700
committerMatt Turner <mattst88@gmail.com>2015-08-03 09:24:23 -0700
commit875458b778e8d389e00f42269e716a3cb2761fab (patch)
tree5db224fb6dfd5d9be69f48ec8ee9581b5c2e110b /configure.ac
parent44e90f2a556a9b8ede12ae18a7cfa3a71e32d40c (diff)
mesa: Add -fno-math-errno to CFLAGS.
Cuts about 9k of .text size. text data bss dec hex filename 4992804 197808 26328 5216940 4f9aac i965_dri.so before 4983676 197808 26328 5207812 4f7704 i965_dri.so after Also, Darwin's libm does not ever set errno, so if we care about those systems we shouldn't rely on errno anyway. Reviewed-by: Roland Scheidegger <sroland@vmware.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 248f6183172..dc9272d3016 100644
--- a/configure.ac
+++ b/configure.ac
@@ -286,6 +286,9 @@ if test "x$GCC" = xyes; then
# Work around aliasing bugs - developers should comment this out
CFLAGS="$CFLAGS -fno-strict-aliasing"
+ # We don't want floating-point math functions to set errno
+ CFLAGS="$CFLAGS -fno-math-errno"
+
# gcc's builtin memcmp is slower than glibc's
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43052
CFLAGS="$CFLAGS -fno-builtin-memcmp"