summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2015-07-31 12:19:46 -0700
committerMatt Turner <mattst88@gmail.com>2015-08-03 09:24:26 -0700
commitf55c408067a3ea3529fcf7cbbaa1a041a4a8849d (patch)
tree1553f9af1139b6e0440647f37330ce8b12425244 /configure.ac
parent875458b778e8d389e00f42269e716a3cb2761fab (diff)
mesa: Add -fno-trapping-math to CFLAGS.
Cuts about 1k of .text size. text data bss dec hex filename 4983676 197808 26328 5207812 4f7704 i965_dri.so before 4982522 197800 26328 5206650 4f727a i965_dri.so after Reviewed-by: Roland Scheidegger <sroland@vmware.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index dc9272d3016..36197d3396a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -286,8 +286,8 @@ if test "x$GCC" = xyes; then
# Work around aliasing bugs - developers should comment this out
CFLAGS="$CFLAGS -fno-strict-aliasing"
- # We don't want floating-point math functions to set errno
- CFLAGS="$CFLAGS -fno-math-errno"
+ # We don't want floating-point math functions to set errno or trap
+ CFLAGS="$CFLAGS -fno-math-errno -fno-trapping-math"
# gcc's builtin memcmp is slower than glibc's
# http://gcc.gnu.org/bugzilla/show_bug.cgi?id=43052