summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2015-06-19 17:46:41 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2015-06-23 17:08:05 +0100
commit994be5143a097ae2cf504ba344362edfee388ac3 (patch)
tree621c7cdd0ff09002c0d72970bc638f64ecaeedc3 /configure.ac
parentddc886b5bfe5976fa2e5f49eeefa918736f1aa97 (diff)
configure: error out when building libEGL without shared-glapi
The latter is a hard requirement and without it we'll error out later on in the build. Cc: "10.5 10.6" <mesa-stable@lists.freedesktop.org> Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Eric Anholt <eric@anholt.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8e62bd893ee..56095baa7e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1543,6 +1543,9 @@ if test "x$enable_egl" = xyes; then
if test "$enable_static" != yes; then
if test "x$enable_dri" = xyes; then
HAVE_EGL_DRIVER_DRI2=1
+ if test "x$enable_shared_glapi" = xno; then
+ AC_MSG_ERROR([egl_dri2 requires --enable-shared-glapi])
+ fi
else
# Avoid building an "empty" libEGL. Drop/update this
# when other backends (haiku?) come along.