summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJose Fonseca <jfonseca@vmware.com>2015-03-19 13:38:52 +0000
committerJose Fonseca <jfonseca@vmware.com>2015-03-22 08:23:24 +0000
commit8f0274c6c645f65a59cb54e14c299cbe131b162d (patch)
tree043c34c95adf321bb259d7ad613df73a2abf84e3 /configure.ac
parent8d5c303ab965c928eef684755c2db9cd441e37ad (diff)
configure: Bail out with MinGW targets.
We only support native Windows builds with SCons. Tested with: ./configure --host=i686-w64-mingw32 Reviewed-by: Brian Paul <brianp@vmware.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 13 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index a8eb0c9d602..08378f570e3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,6 +46,13 @@ AC_CONFIG_MACRO_DIR([m4])
AC_CANONICAL_SYSTEM
AM_INIT_AUTOMAKE([foreign tar-ustar dist-xz])
+dnl We only support native Windows builds (MinGW/MSVC) through SCons.
+case "$host_os" in
+mingw*)
+ AC_MSG_ERROR([MinGW build not supported through autoconf/automake, use SCons instead])
+ ;;
+esac
+
# Support silent build rules, requires at least automake-1.11. Disable
# by either passing --disable-silent-rules to configure or passing V=1
# to make
@@ -651,7 +658,7 @@ AC_CHECK_FUNCS([dladdr])
LIBS="$save_LIBS"
case "$host_os" in
-darwin*|mingw*)
+darwin*)
;;
*)
AC_CHECK_FUNCS([clock_gettime], [CLOCK_LIB=],
@@ -665,16 +672,10 @@ dnl See if posix_memalign is available
AC_CHECK_FUNC([posix_memalign], [DEFINES="$DEFINES -DHAVE_POSIX_MEMALIGN"])
dnl Check for pthreads
-case "$host_os" in
-mingw*)
- ;;
-*)
- AX_PTHREAD
- if test "x$ax_pthread_ok" = xno; then
- AC_MSG_ERROR([Building mesa on this platform requires pthreads])
- fi
- ;;
-esac
+AX_PTHREAD
+if test "x$ax_pthread_ok" = xno; then
+ AC_MSG_ERROR([Building mesa on this platform requires pthreads])
+fi
dnl AX_PTHREADS leaves PTHREAD_LIBS empty for gcc and sets PTHREAD_CFLAGS
dnl to -pthread, which causes problems if we need -lpthread to appear in
dnl pkgconfig files.
@@ -905,7 +906,7 @@ AM_CONDITIONAL(HAVE_DRI_GLX, test "x$enable_glx" = xyes -a \
case "$host_os" in
darwin*)
dri_platform='apple' ;;
-gnu*|mingw*|cygwin*)
+gnu*|cygwin*)
dri_platform='none' ;;
*)
dri_platform='drm' ;;