summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Gray <jsg@jsg.id.au>2015-10-10 17:42:40 +1100
committerEmil Velikov <emil.l.velikov@gmail.com>2015-10-21 14:23:22 +0100
commit6d6a4d7c767d7d8be0ddab8e47855f16695cfb30 (patch)
tree1a28122f424cf35ef0a9bd256aa7eccb973b913a /configure.ac
parent13276962c7e7a490c68bb6479f770e2d145818b8 (diff)
configure.ac: ensure RM is set
GNU make predefines RM to rm -f but this is not required by POSIX so ensure that RM is set. This fixes "make clean" on OpenBSD. v2: use AC_CHECK_PROG Signed-off-by: Jonathan Gray <jsg@jsg.id.au> CC: "10.6 11.0" <mesa-stable@lists.freedesktop.org> Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com> (cherry picked from commit 99c4079c37ac04a0dad4ead3117f786706c80aaf)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 92799c65ae5..1751413fa04 100644
--- a/configure.ac
+++ b/configure.ac
@@ -106,6 +106,8 @@ AC_SYS_LARGEFILE
LT_PREREQ([2.2])
LT_INIT([disable-static])
+AC_CHECK_PROG(RM, rm, [rm -f])
+
AX_PROG_BISON([],
AS_IF([test ! -f "$srcdir/src/glsl/glcpp/glcpp-parse.c"],
[AC_MSG_ERROR([bison not found - unable to compile glcpp-parse.y])]))