summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Iglesias Gonsalvez <siglesias@igalia.com>2015-03-02 10:49:31 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2015-03-26 01:47:12 +0000
commite98909b0567b8a83a6a953cfa4ee4e7beef436b9 (patch)
treec7adc6741ecc0f54f4f350296e07b02af35682e5 /configure.ac
parentd83d2ea9a6562314388c0a1941137001960b6453 (diff)
configure: Introduce new output variable to ax_check_python_mako_module.m4
This output variables gives more flexibility for future changes in autoconf to detect if it is needed to auto-generate files and check for the auto-generation dependencies. It is still returning error when Python is not installed. Signed-off-by: Samuel Iglesias Gonsalvez <siglesias@igalia.com> Reviewed-by: Kai Wasserbäch <kai@dev.carbon-project.org> (cherry picked from commit ced9425327be6cb557a4a1217a1dac29b18d1a09) Squashed with commit configure.ac: move AC_MSG_RESULT reporting back into the m4 macro The one who does AC_MSG_CHECKING should provide the AC_MSG_RESULT. Fixes: ced9425327b (configure: Introduce new output variable to ax_check_python_mako_module.m4" Cc: "10.5" <mesa-stable@lists.freedesktop.org> Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=89328 Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Samuel Iglesias Gonsalvez <siglesias@igalia.com> (cherry picked from commit 248eb54eb6117cc5a863ba2deaa14c3bee0b5d41)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index f596a9d2d31..20e6d629a44 100644
--- a/configure.ac
+++ b/configure.ac
@@ -78,6 +78,7 @@ XCBDRI2_REQUIRED=1.8
XCBGLX_REQUIRED=1.8.1
XSHMFENCE_REQUIRED=1.1
XVMC_REQUIRED=1.0.6
+PYTHON_MAKO_REQUIRED=0.3.4
dnl Check for progs
AC_PROG_CPP
@@ -113,7 +114,10 @@ if test "x$INDENT" != "xcat"; then
fi
fi
-AX_CHECK_PYTHON_MAKO_MODULE(0.3.4)
+AX_CHECK_PYTHON_MAKO_MODULE($PYTHON_MAKO_REQUIRED)
+if test -n "$PYTHON2" -a "x$acv_mako_found" != "xyes"; then
+ AC_MSG_ERROR([Python mako module v$PYTHON_MAKO_REQUIRED or higher not found])
+fi
AC_PROG_INSTALL