summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBrian Paul <brianp@vmware.com>2013-02-26 08:49:34 -0700
committerAndreas Boll <andreas.boll.dev@gmail.com>2013-05-01 21:34:48 +0200
commit4ede5fb0c6e19c47155138993de47772a27f9db3 (patch)
tree950d9faa2be323a5c665b96a15f712a3dae6f80f /configure.ac
parent6b8f55c4da11f892bcbc878fc92c7119aaabf674 (diff)
configure: remove FEATURE_GL/ES1/ES2
Not used anymore. v2: Andreas Boll <andreas.boll.dev@gmail.com> - split patch into two patches Reviewed-by: Matt Turner <mattst88@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 1 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index d8555185c16..d7f241919d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -688,17 +688,6 @@ if test "x$enable_opengl" = xno -a \
fi
API_DEFINES=""
-if test "x$enable_opengl" = xno; then
- API_DEFINES="$API_DEFINES -DFEATURE_GL=0"
-else
- API_DEFINES="$API_DEFINES -DFEATURE_GL=1"
-fi
-if test "x$enable_gles1" = xyes; then
- API_DEFINES="$API_DEFINES -DFEATURE_ES1=1"
-fi
-if test "x$enable_gles2" = xyes; then
- API_DEFINES="$API_DEFINES -DFEATURE_ES2=1"
-fi
AC_SUBST([API_DEFINES])
AM_CONDITIONAL(HAVE_OPENGL, test "x$enable_opengl" = xyes)
@@ -957,7 +946,7 @@ DRI_DIRS=""
case "$with_dri_drivers" in
no) ;;
yes)
- # classic DRI drivers require FEATURE_GL to build
+ # classic DRI drivers
if test "x$enable_opengl" = xyes; then
DRI_DIRS="yes"
fi