summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2013-01-20 12:54:31 -0800
committerMatt Turner <mattst88@gmail.com>2013-04-15 12:05:55 -0700
commit2f7a37d858ecafa51e70eb8aeb9b7cfcfaf2fa0e (patch)
tree7f8ebcc811f8a5eba492efb3d238d53d011846aa /configure.ac
parent0d3b1b0e2eb9212d95cd590848b059ebdae46da9 (diff)
build: Build pipe-loader before gallium tests
And don't build it from other Makefiles. That's awful, and breaks distclean. Tested-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-and-Tested-by: Andreas Boll <andreas.boll.dev@gmail.com> Reviewed-by: Jordan Justen <jordan.l.justen@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index de51b17c018..805a355729d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1397,10 +1397,6 @@ if test "x$enable_opencl" = xyes; then
fi
AM_CONDITIONAL(HAVE_CLOVER, test "x$enable_opencl" = xyes)
-if test "x$enable_gallium_gbm" = xyes || test "x$enable_opencl" = xyes; then
- GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS pipe-loader"
-fi
-
dnl
dnl Gallium configuration
dnl
@@ -1666,6 +1662,10 @@ if test "x$enable_gallium_tests" = xyes; then
fi
AM_CONDITIONAL(HAVE_GALLIUM_TESTS, test "x$enable_gallium_tests" = xyes)
+if test "x$enable_gallium_loader" = xyes; then
+ GALLIUM_TARGET_DIRS="$GALLIUM_TARGET_DIRS pipe-loader"
+fi
+
dnl Directory for VDPAU libs
AC_ARG_WITH([vdpau-libdir],
[AS_HELP_STRING([--with-vdpau-libdir=DIR],