summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2014-05-15 22:54:48 +0100
committerCarl Worth <cworth@cworth.org>2014-06-23 11:39:28 -0700
commitd6d80b44c48487d72ef1b2fdd1e55018e2b149fc (patch)
tree0ecd58ac121916d5e524b5a9eee14ae6d8c7a7c5 /configure.ac
parenta5d00e243c12bbf0306a0435f20f2804451e0a6a (diff)
configure: error out when building opencl without LLVM
Cc: Tom Stellard <thomas.stellard@amd.com> Cc: "10.1 10.2" <mesa-stable@lists.freedesktop.org> Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Tom Stellard <thomas.stellard@amd.com> (cherry picked from commit 93257a56b5b585e79e4ba9f95b38f5bd718e3959)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 164b662d0e0..02397387029 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1387,6 +1387,10 @@ if test "x$enable_opencl" = xyes; then
AC_MSG_ERROR([cannot enable OpenCL without Gallium])
fi
+ if test "x$enable_gallium_llvm" != xyes; then
+ AC_MSG_ERROR([cannot enable OpenCL without LLVM])
+ fi
+
if test $GCC_VERSION_MAJOR -lt 4 -o $GCC_VERSION_MAJOR -eq 4 -a $GCC_VERSION_MINOR -lt 7; then
AC_MSG_ERROR([gcc >= 4.7 is required to build clover])
fi