summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2014-03-08 19:48:04 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2014-03-11 12:50:43 +0000
commitbba9c28215f96a6570c290906b64eea83383beb8 (patch)
tree2d15abc85471ba4922e8df3138e89d158fc91a92 /configure.ac
parent020bc0d0dd2e71dd32d6e16e3c18acd79c328b0b (diff)
configure: use LIB_EXT rather than hardcoded .so
Some platforms different library extension - dll, dylib, a. Honor that when we are creating the required links. Rename LIB_EXTENSION to LIB_EXT while we're here. With libglapi linking aside, building classic drivers on non-linux platforms should be possible now. v2: Resolve conflicts. Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Jon TURNEY <jon.turney@dronecode.org.uk>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 6141a5493e6..5e1d09166ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -320,19 +320,22 @@ dnl
dnl library names
dnl
if test "$enable_static" = yes; then
- LIB_EXTENSION='a'
+ LIB_EXT='a'
else
case "$host_os" in
darwin* )
- LIB_EXTENSION='dylib' ;;
+ LIB_EXT='dylib' ;;
cygwin* )
- LIB_EXTENSION='dll' ;;
+ LIB_EXT='dll' ;;
aix* )
- LIB_EXTENSION='a' ;;
+ LIB_EXT='a' ;;
* )
- LIB_EXTENSION='so' ;;
+ LIB_EXT='so' ;;
esac
fi
+
+AC_SUBST([LIB_EXT])
+
AC_ARG_WITH([gl-lib-name],
[AS_HELP_STRING([--with-gl-lib-name@<:@=NAME@:>@],
[specify GL library name @<:@default=GL@:>@])],