summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gmail.com>2012-10-01 13:11:30 -0700
committerMatt Turner <mattst88@gmail.com>2013-01-22 14:33:31 -0800
commitb68b85224d38fe9c1f6e10af338e1ff2519e689b (patch)
treeff40a52b3d0222730e3bc2ed2360719359105fd3 /configure.ac
parent3791ce05eb3c169c55b1d6eb5e613684e2cec4df (diff)
build: Use AX_PROG_BISON
No one tests yacc/byacc. Let's just request bison specifically. Tested-by: Andreas Boll <andreas.boll.dev@gmail.com> Reviewed-by: Eric Anholt <eric@anholt.net> Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=46815
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index f338e20c7e5..70599e1d33e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -56,13 +56,9 @@ AC_PROG_MKDIR_P
LT_PREREQ([2.2])
LT_INIT([disable-static])
-AC_PROG_YACC
-AC_PATH_PROG([YACC_INST], $YACC)
-if test ! -f "$srcdir/src/glsl/glcpp/glcpp-parse.c"; then
- if test -z "$YACC_INST"; then
- AC_MSG_ERROR([yacc not found - unable to compile glcpp-parse.y])
- fi
-fi
+AX_PROG_BISON([],
+ AS_IF([test ! -f "$srcdir/src/glsl/glcpp/glcpp-parse.c"]
+ [AC_MSG_ERROR([bison not found - unable to compile glcpp-parse.y])]))
AC_PROG_LEX
AC_PATH_PROG([PERL], [perl])