summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKeith Packard <keithp@keithp.com>2013-11-21 20:22:16 -0800
committerKenneth Graunke <kenneth@whitecape.org>2013-12-20 16:17:54 -0800
commit568a27588d13146d0fd7cb4e775e1ac0187e5e29 (patch)
tree06bca12d062d61a2082bbceb63a10761a8d3bbaa /configure.ac
parent9f330481c3979724300881891dfa17e99a5698ab (diff)
dri3: Switch to libxshmfence version 1.1
libxshmfence v1.0 foolishly used 'int32_t *' for the fence type, which works when the fence is a linux futex. However, version 1.1 changes the exported datatype to 'struct xshmfence *' Require libxshmfence version 1.1 and switch the API around. Signed-off-by: Keith Packard <keithp@keithp.com> Reviewed-by: Kenneth Graunke <kenneth@whitecape.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b0e2b4c3844..07680c09a11 100644
--- a/configure.ac
+++ b/configure.ac
@@ -836,7 +836,7 @@ xyesno)
dri_modules="x11 xext xdamage xfixes x11-xcb xcb-glx >= 1.8.1 xcb-dri2 >= 1.8"
if test x"$enable_dri3" = xyes; then
- dri_modules="$dri_modules xcb-dri3 xcb-present xcb-sync xshmfence"
+ dri_modules="$dri_modules xcb-dri3 xcb-present xcb-sync xshmfence >= 1.1"
fi
# add xf86vidmode if available