summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNiels Ole Salscheider <niels_ole@salscheider-online.de>2013-04-04 23:26:45 +0200
committerTom Stellard <thomas.stellard@amd.com>2013-04-08 07:08:10 -0700
commitb336f51cc72a3290b39ead5c76ca36156562c0bd (patch)
tree20d5edd170e5354f32f3e575080d71825a1168aa
parent5019af21453d0e9fc5b0f8c1c2bfeb29029882c1 (diff)
clover: Fix linkage of libOpenCL
Clover needs the irreader component of llvm v2: Check for irreader component irreader is only available with LLVM 3.3 >= 177971 Reviewed-by: Tom Stellard <thomas.stellard@amd.com> Signed-off-by: Niels Ole Salscheider <niels_ole@salscheider-online.de>
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 81d4a3f3ea3..fea586845a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1650,6 +1650,10 @@ if test "x$enable_gallium_llvm" = xyes; then
if test "x$enable_opencl" = xyes; then
LLVM_COMPONENTS="${LLVM_COMPONENTS} ipo linker instrumentation"
+ # LLVM 3.3 >= 177971 requires IRReader
+ if $LLVM_CONFIG --components | grep -q '\<irreader\>'; then
+ LLVM_COMPONENTS="${LLVM_COMPONENTS} irreader"
+ fi
fi
LLVM_LDFLAGS=`$LLVM_CONFIG --ldflags`
LLVM_BINDIR=`$LLVM_CONFIG --bindir`