summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorEric Engestrom <eric.engestrom@imgtec.com>2018-02-26 15:42:18 +0000
committerEric Engestrom <eric.engestrom@imgtec.com>2018-03-05 17:34:01 +0000
commit7a58c21f3ef3fd9f47d9f73cc9d725996ad691a0 (patch)
tree9d45a25456f9d99def9ca3c8592ef0b5a45f71cb /meson.build
parenta1a13d2002666922dbc7530c6f16aad600c3c3f3 (diff)
meson: add configuration summary
The message block printed is the same as the one in configure.ac Signed-off-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build17
1 files changed, 17 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 15a2b084..7bf26819 100644
--- a/meson.build
+++ b/meson.build
@@ -373,3 +373,20 @@ if with_man_pages
endif
subdir('data')
subdir('tests')
+
+message('')
+message('@0@ will be compiled with:'.format(meson.project_name()))
+message('')
+message(' libkms @0@'.format(with_libkms))
+message(' Intel API @0@'.format(with_intel))
+message(' vmwgfx API @0@'.format(with_vmwgfx))
+message(' Radeon API @0@'.format(with_radeon))
+message(' AMDGPU API @0@'.format(with_amdgpu))
+message(' Nouveau API @0@'.format(with_nouveau))
+message(' OMAP API @0@'.format(with_omap))
+message(' EXYNOS API @0@'.format(with_exynos))
+message(' Freedreno API @0@ (kgsl: @1@)'.format(with_freedreno, with_freedreno_kgsl))
+message(' Tegra API @0@'.format(with_tegra))
+message(' VC4 API @0@'.format(with_vc4))
+message(' Etnaviv API @0@'.format(with_etnaviv))
+message('')