summaryrefslogtreecommitdiff
path: root/NEWS
blob: fb92b6dfd4d4cf46cc055ffff9156f737e6950cd (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
143
144
145
146
147
148
149
150
151
152
153
154
155
156
157
158
159
160
161
162
163
164
165
166
167
168
169
170
171
libspectre 0.2.8 (01 July 2016)
===============================

This is another bugfix only release in the libspectre's 0.2 series.

Marek fixed the document rotation with newer versions of Ghostscript (Bug #76450)

Build was also broken with Ghostscript >= 9.18 and has been fixed.

Fixed a compile warning due to a comparison of integers of different
signs reported by Daniel Macks when building on OS X (Bug #56476)

Makefiles were updated to properly use CPPFLAGS instead of CFLAGS as
suggested by Daniel Macks (Bug #56481)


libspectre 0.2.7 (08 August 2012)
=================================

This is another bugfix only release in the libspectre's 0.2 series.

This release fixes two crashes than can happen when %%Pages: or
%%Page: comments are missing in the document or when %%Pages: comment
is present but it's invalid.


libspectre 0.2.6 (10 June 2010)
===============================

This is another bugfix only release in the libspectre's 0.2 series.

The most important change in this release is that gs is now always
initalized with the flag -P- to make Ghostscript not look in the
current directory for library files. See Debian bug
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=583183

Compiler flags -ansi and -pedantic are now optional and can be enabled
with --enable-iso-c configure option. It seems -pedantic causes
performance regression when compiling with Sun Studio compiler. Thanks
to Dagobert Michelsen for eporting the issue. (Bug #27735)

Files with a doseps header and without EOF comment are correctly
rendered now. (Bug #27830)


libspectre 0.2.5 (18 April 2010)
================================

This is another bugfix only release in the libspectre's 0.2 series.

This release contains two important fixes:

 - The first one is a portability issue that caused crashes on
   big-endian 64 bit systems. Thanks to Rogério Brito who spotted the
   problem, see launchpad bug
   https://bugs.launchpad.net/ubuntu/+source/libspectre/+bug/298139

 - The second one is a crash when something goes wrong while running
   pdf exporter. (Bug #26592)


libspectre 0.2.4 (21 February 2010)
===================================

This is another bugfix only release in the libspectre's 0.2 series.

Documents containing embedded documents inside the prolog,
typically font resources, were not correctly rendered (Bug #25573)

Hib Eris fixed some portability issues to make libspectre build and
work on Windows (Bug #26377)

PDF exporter was broken which might cause a crash when printing some
documents (Bug #26592)


libspectre 0.2.3 (18 October 2009)
==================================

This is another bugfix only release in the libspectre's 0.2 series.

Several fixes in the PostScript parser:

 - Detection of invalid or broken files has been improved. A document
   scanned without errors with no pages and no format is likely to be
   an invalid file, or not a PostScript file at all (Bug #19042)

 - Fix possible uninitialized use of Document media struct
   contents. Thanks to Alexander Myltsev (Bug #18685)

 - Fix documents with PJL commands before the initial DSC comments.

Ghostscript is now always run with -dSAFER option

A missing argument in gs command line of PDF exporter was making it
always fail for any document in BSD systems. Thanks to Antoine
Jacoutot who gave me remote access to an OpenBSD system to fix this
(Bug #18826)

Internal copy of ghostscript headers have been removed since they are
already installed by ghostscript since version 8.62 (Bug #18827)


libspectre 0.2.2 (25 November 2008)
===================================

This is another bugfix only release in the libspectre's 0.2 series.

A problem when rendering some documents where the page size is
different from the Bounding Box has been fixed (Bug #18239)

Parser is now locale-independent when parsing float numbers (Bug #18685)

The display format has been fixed to match cairo/pixman. Thanks to
Chris Wilson (Bug #18266)


libspectre 0.2.1 (10 August 2008)
=================================

This is a bugfix only release. There are no API changes at all.

Fixes and improvements in the PostScript parser:

 - Support DOS EPS files (Bug #16810)
 - A work around for some invalid documents generated by some versions
   of Mozilla has been added. (Bug #14384)
 - PS-AdobeFont comments are not considered as begining of a nested
   document anymore so that the font code is not ignored. 

Portability fixes:

 - Alternative implementation of spectre_strdup_vprintf for platforms
   where vasprintf is not available (Bug #15127)
 - Implement _spectre_get_pid for win32 (Bug #16309)
 - Open files in binary mode for win32 compatibility (Bug #16309)
 - Fix endianness bug
   
Several cleanups and improvements have been made in the code and lots
of compile warnings have been fixed. 


libspectre 0.2.0 (03 January 2008)
==================================

API additions:

 - Rendering unstructured documents: it's a bit confusing calling
   get_page for a document with no pages. The following functions has
   been added for rendering unstructured documents:
   
    * spectre_document_render
    * spectre_document_render_full
    * spectre_document_get_page_size
   
 - Tile rendering: spectre_page_render_slice has been added to allow
   rendering rectangles of the page. (Bug #13754)

API changes:

 - spectre_render_context_set_page_size determines the size of the
   output image, but it doesn't affect the scale factor anymore.

 - spectre_render_context_[set|get]_scale now require the scale factor for
   both the X and Y dimensions.


libspectre 0.1.0 (16 December 2007)
===================================

This is the first public release of libspectre.