summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJan Holesovsky <kendy@collabora.com>2019-02-13 17:28:01 +0100
committerJan Holesovsky <kendy@collabora.com>2019-02-13 17:28:01 +0100
commit7a0209c7aa6e927894459e3fd6f992c11eb32125 (patch)
tree9861ced98713c295dce84a9bb753565d65105ccb /configure.ac
parent7f0f6e5a36e28981a4954e60c2c1911b12d932d7 (diff)
android: Link against the debug POCO libraries if --enable-debug.
Change-Id: Ic7dc3076a12fe9a0faf4dec5c0f5b0b3a5a171c3
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 32cf66d8f..34db534e8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -237,6 +237,7 @@ fi
LOBUILDDIR=
POCOINCLUDE=
POCOLIB=
+POCODEBUG=
if test \( "$enable_iosapp" = "yes" -a `uname -s` = "Darwin" \) -o \( "$enable_androidapp" = "yes" \); then
AC_MSG_CHECKING([for LibreOffice build tree to build against])
if test -z "$with_lo_builddir"; then
@@ -276,10 +277,15 @@ if test \( "$enable_iosapp" = "yes" -a `uname -s` = "Darwin" \) -o \( "$enable_a
else
AC_MSG_ERROR([This is not a Poco lib directory: $POCOLIB])
fi
+
+ if test "$ENABLE_DEBUG" = "true" ; then
+ POCODEBUG=d
+ fi
fi
AC_SUBST(LOBUILDDIR)
AC_SUBST(POCOINCLUDE)
AC_SUBST(POCOLIB)
+AC_SUBST(POCODEBUG)
LIBPNG_INCLUDES="$with_libpng_includes"
LIBPNG_LIBS="$with_libpng_libs"