summaryrefslogtreecommitdiff
path: root/sw/source/uibase/wrtsh/navmgr.cxx
AgeCommit message (Collapse)AuthorFilesLines
2021-01-18tdf#115817 set standard mode before recency navigationJim Raykowski1-3/+1
Using Navigate-by to move through the recency stack sets the writer shell to standard mode before navigation. Navigation using the Back and Forward navigation controls does not. This results in incorrect behaviour when a drawing object is selected and navigation is attempted. This patch sets writer shell to standard mode before recency navigation is done using .uno:NavigateBack and .uno:NavigateForward. Change-Id: If05883e8188452736cfedac9153bcc91422bf7e8 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/109504 Tested-by: Jenkins Reviewed-by: Jim Raykowski <raykowj@gmail.com>
2021-01-17tdf#115817 add places that add current position to navigation managerJim Raykowski1-0/+8
Change-Id: If011b51fac6587b4f551a498866aa71f62ba0fcc Reviewed-on: https://gerrit.libreoffice.org/c/core/+/108529 Reviewed-by: V, Stuart Foote <vstuart.foote@utsa.edu> Reviewed-by: Jim Raykowski <raykowj@gmail.com> Tested-by: Jenkins
2021-01-14tdf#115817 Add navigation recency to Navigate ByJim Raykowski1-25/+0
- Adds Recency to Navigate By and when selected, previous and next scroll controls navigate the navigation manager stack backwards and forward. - Removes the code that makes the Navigation tool bar appear when an entry is added to the navigation manager stack so the tool bar doesn't appear unless the user explicilty chooses for it to. - Changes Navigation toolbar context sensitivity to false. Change-Id: I246dd442b4bc5191324c35f9b91a9cb2eac8e7f4 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/108316 Tested-by: Jenkins Reviewed-by: Jim Raykowski <raykowj@gmail.com>
2020-07-30loplugin:flatten in sw/uibase/utl..sw/uibase/wrtshNoel Grandin1-41/+41
Change-Id: I9010524952ce3b99a62e53dbf715a72c86a89b01 Reviewed-on: https://gerrit.libreoffice.org/c/core/+/99766 Tested-by: Jenkins Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>
2019-08-15replace ".get->" with "->"Noel Grandin1-1/+1
Change-Id: I327a6fda1fe0170da33e06b735f09a39421c8a58 Reviewed-on: https://gerrit.libreoffice.org/77469 Tested-by: Jenkins Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>
2019-08-05tdf#42949 Fix IWYU warnings in sw/source/uibase/inc/[l-z]*Gabor Kelemen1-0/+1
Found with bin/find-unneeded-includes Only removal proposals are dealt with here. Change-Id: Ie1c889bb9bd74b0d2bd859dad4c85a209db750a3 Reviewed-on: https://gerrit.libreoffice.org/76503 Tested-by: Jenkins Reviewed-by: Miklos Vajna <vmiklos@collabora.com>
2019-03-29tdf#42949 Fix IWYU warnings in include/sfx2/[n-r]*Gabor Kelemen1-0/+1
Found with bin/find-unneeded-includes Only removal proposals are dealt with here. Change-Id: Ia2bea9bd4775f4ed5ef0133971106a6c0bfdd1c0 Reviewed-on: https://gerrit.libreoffice.org/69896 Tested-by: Jenkins Reviewed-by: Miklos Vajna <vmiklos@collabora.com>
2018-10-30Simplify containers iterations in sw/source/ui*Arkadiy Illarionov1-7/+5
Use range-based loop or replace with STL functions. Change-Id: I0d690e873f720a68f04991674ce84ec590231fd0 Reviewed-on: https://gerrit.libreoffice.org/62432 Tested-by: Jenkins Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>
2018-10-17clang-tidy readability-redundant-smartptr-getNoel Grandin1-2/+2
redundant get() call on smart pointer Change-Id: Icb5a03bbc15e79a30d3d135a507d22914d15c2bd Reviewed-on: https://gerrit.libreoffice.org/61837 Tested-by: Jenkins Reviewed-by: Noel Grandin <noel.grandin@collabora.co.uk>
2017-10-09uibase: consistently use "" and <> in include directivesMike Kaganski1-2/+2
Change-Id: Ib6888045cecb4bd7b3498534605d790324f1b40a Reviewed-on: https://gerrit.libreoffice.org/43265 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Mike Kaganski <mike.kaganski@collabora.com>
2017-05-18Revert "Fix typos"Stephan Bergmann1-1/+1
This reverts commit 26a67002fcb9381b54de6cae1aaa37120d49066a. "Iff" is not a typo, see 2a65bf32ec270484dcea4d22d3c93552dc0c24dd "Revert 'Typo: iff->if'".
2017-05-18Fix typosAndrea Gelmini1-1/+1
Only replaced "iff" with "if" Change-Id: Ib9dfa5c12b05500043147fe3b65f923b1b12a581 Reviewed-on: https://gerrit.libreoffice.org/37782 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Eike Rathke <erack@redhat.com>
2017-04-26tdf#107427 sw: fix crash with stale entries in SwNavigationMgrMichael Stahl1-0/+30
When deleting a header, the sw::UnoCursorPointer of SwNavigationMgr spontaneously self-destructs, but SwNavigationMgr expects its cursors to always be alive, so add another SfxListener to remove dying cursors. (probably regression from a2c467a58ade9f55e0154b2935c747bb283ebd45) Change-Id: I1055ea3cfc47114dc36002198f1ddffea87d2d85
2017-03-25Fix typosAndrea Gelmini1-1/+1
Change-Id: I52604902247e7d8565476fafe98211fff32c5543 Reviewed-on: https://gerrit.libreoffice.org/35658 Reviewed-by: Julien Nabet <serval2412@yahoo.fr> Tested-by: Julien Nabet <serval2412@yahoo.fr>
2016-06-16Remove the :: prefix in ::std for swMark Page1-1/+1
This patch was created using a script Variable name textual alignment is preserved to the same level Change-Id: I6b4858f8059b8cf71fc253e87d6df634362d62e9 Reviewed-on: https://gerrit.libreoffice.org/26306 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Stephan Bergmann <sbergman@redhat.com>
2015-11-25bin/rename-sw-abbreviations.shlibreoffice-5-1-branch-pointRobinson Tryon1-4/+4
This commit renames the most annoying abbreviations in Writer (and partially in the shared code too). Change-Id: I77e5134f42f25e3786afa36b7a505c7e3237a9e8
2015-06-23Revert "Typo: iff->if"Julien Nabet1-1/+1
This reverts commit cf92da3d6e1de14756efe3f1ee79f393a2f3787d. iff can mean "if and only if" so not a typo
2015-06-23Typo: iff->ifJulien Nabet1-1/+1
Change-Id: I3fc60856b5a56e71d70b55c89323be074bdec3b3
2015-06-09use UnoCursorPointer in SwNavigationMgrBjoern Michaelsen1-14/+2
Change-Id: I7c7431edd79cf4527f97c7dc0695d49174b61e2c
2015-05-26now rename the new CreateUnoCrsr2 to CreateUnoCrsr, as the old stuff is goneBjoern Michaelsen1-2/+2
Change-Id: I82f8ed0560750d4f7bec71ea8bd3c8089b884da7
2015-05-26make SwNavigationMgr use the shared_ptrBjoern Michaelsen1-4/+17
- also make it listen to at least one of the SwUnoCrsr it keeps on the heap for document disposing. - as the SwNavigationMgr lives longer than the document this was actually a double free before: first from SwUnoCrsrTbl dtor an then from the shared_ptr in SwNavigationMgr Change-Id: Ia75ad81a978ca37ed2a94fd221427b62e99e1bb3
2015-05-26remove unconditionally dead codeBjoern Michaelsen1-14/+2
Change-Id: Idf092ad98ac029eda11fa9b925cf7a99bf3c5167
2014-06-22Fix pathsJulien Nabet1-2/+2
Change-Id: Idc756bc1b224952b9283fd15b3313b70ea3828a3
2014-05-27sw: move sw/source/core/uibase to sw/source/uibaseMichael Stahl1-0/+228
It's too confusing to have UI code inside of core; the important part is that it's separated from the optional UI code in swui library. Change-Id: I640a52723d5802faf08f3b8eaa03cd937fd93449