summaryrefslogtreecommitdiff
path: root/formula
AgeCommit message (Collapse)AuthorFilesLines
2016-08-18screenshots: add new global make targetArmin Le Grand1-1/+2
Up to now the screenshot creation was added/dependent of target slowcheck. Since quite some modules have added screenshot creations now, I added an own target 'screenshot' to allow to keep current slowcheck and screenshot creation separated Change-Id: I80a49a0db607edf8e0405672d570f624d29912e7
2016-08-18screenshots: unify dumping of dialog test batch fileArmin Le Grand1-74/+2
Change-Id: Ia1e79216d9537c65f8b7362778a2e1ad3ec6c2c2
2016-08-18screenshots: add dialog test cases for formulaArmin Le Grand4-0/+255
Change-Id: I2fb495dd8603b00127504240e4bec16726c2153f
2016-08-05loplugin:countusersofdefaultparams in editeng..fpickerNoel Grandin1-4/+4
Change-Id: I6356c95296d81736fc6d66e510cd70606ee55f68 Reviewed-on: https://gerrit.libreoffice.org/27897 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Noel Grandin <noelgrandin@gmail.com>
2016-08-03Resolves: tdf#69539 UI rename CONVERT to CONVERT_OOO, CONVERT_ADD to CONVERTEike Rathke1-4/+4
... with same syntax but different semantics that was even more confusing. Change-Id: Ibe1efcd5c4e82c9ce8d9fe8ed0f85e86dac327f7
2016-08-03rename ocConvert to ocConvertOOo and relatedEike Rathke2-7/+7
... to clarify that this is not the "real" CONVERT function. Change-Id: Ia71949ffabd2c983be0dbf9fa36bb8c52f0077ee
2016-08-03UI rename DURATION to PDURATION, DURATION_ADD to DURATION, tdf#50488 relatedEike Rathke1-4/+4
Change-Id: I7ba783b59a711fc9c9d6bbe68dcf8c3c1a0d409d
2016-08-03rename ocDuration to ocPDuration and relatedEike Rathke1-6/+6
... to clarify that these belong to PDURATION (currently DURATION in UI) instead of DURATION (currently DURATION_ADD in UI). The confusing UI name situation will be resolved separately. Change-Id: I09a7bc8437be1c4c9e72f94e61c877111fb48806
2016-08-03use GRAM_API instead of GRAM_PODF_A1 in API contextEike Rathke1-1/+1
... which right now is identical but may get corrections in future. Change-Id: Id4e1707afb32a3d8e073705072e5e65105f2a14a
2016-08-03InitSymbolsAPI() for FormulaLanguage::APIEike Rathke1-11/+5
Change-Id: I203557ed50d0d54fe9977e3d51e7f979551b472b
2016-08-03introduce formula::FormulaGrammar::Grammar::GRAM_APIEike Rathke1-0/+1
Change-Id: Iceaf114847129f0b014ffd61d547e131baf1f07b
2016-08-02introduce mxSymbolsAPI and InitSymbolsAPI()Eike Rathke1-0/+21
Change-Id: I1c4673a25bb0f686e0705f87318a04166e6688bb
2016-08-02InitSymbolsPODF() from RID_STRLIST_FUNCTION_NAMES_ENGLISH_PODFEike Rathke1-1/+1
Change-Id: I03f8d183303b869a4cfaa76ea4170da95574e5d5
2016-08-02prepare to disentangle RID_STRLIST_FUNCTION_NAMES_ENGLISHEike Rathke2-7/+901
RID_STRLIST_FUNCTION_NAMES_ENGLISH grew to a conglomerate of English UI names, names used in PODF (ODF 1.0/1.1) and XFunctionAccess API names. Copy it to independent resources so we can start to correct names in English UI, keep PODF oddnesses and cater for API compatibility needs. Change-Id: I7c2053d7627c4da220d8fc991158e8e7a81f0b37
2016-08-01keep a broken expression as originally brokenEike Rathke1-0/+1
The invalid expression ISOWEEKNUM(A1,0+) lead to a replacement with ISOWEEKNUM(A1+) which of course is also wrong but loses the original context. Just exchange the call and convert to WEEKNUM_OOO(A1,0+) without fiddling with the parameters. Change-Id: Id1c42d3ba084382e09c164b6c35db996f2b0197a
2016-08-01refine ISOWEEKNUM vs WEEKNUM_OOO detectionEike Rathke1-1/+4
Change-Id: I7cf5d51946235ea1bc6a4d0999fa98e1a3f8a095
2016-07-27improve passstuffbyref return analysisNoel Grandin1-2/+2
Change-Id: I4258bcc97273d8bb7a8c4879fac02a427f76e18c Reviewed-on: https://gerrit.libreoffice.org/27317 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Noel Grandin <noelgrandin@gmail.com>
2016-07-15loplugin:commaoperatorStephan Bergmann1-1/+1
Change-Id: I7ba83b999b3b12411348c21cabcd47b8ad9c4034
2016-07-14strip second parameter from ISOWEEKNUM if literal double != 1.0Eike Rathke1-11/+0
For other arguments convert to WEEKNUM_OOO, which now can be saved as ORG.LIBREOFFICE.WEEKNUM_OOO. Change-Id: I63fd3df1ec4ccaa535a1437200854d8734544a2c
2016-07-14store WEEKNUM_OOO as ORG.LIBREOFFICE.WEEKNUM_OOOEike Rathke2-19/+0
Now that the previous two releases can read it. Change-Id: Ie04c7b0fd94f5906b678d738370e4fc0696da79c
2016-07-14let FormulaTokenArray::RemoveToken() return the actual count of tokens removedEike Rathke1-1/+3
Change-Id: Iebf654e7b4c682036b4ff334298948557b755eac
2016-07-14re-add FormulaTokenArray::ReplaceToken() that was removed as unused, grml..Eike Rathke1-0/+54
with 4ff5a5558472beee85eb1234dcc2aa2ed9000f6c Change-Id: Id99c3ae74515f24c55a3734698c560dcac8bacd9
2016-07-14yet more functions to save with prefix and namespace to OOXMLEike Rathke1-5/+5
MULTIRANGE, GOALSEEK, EASTERSUNDAY, CURRENT and STYLE are LibreOffice / OpenOffice.org only and need a _xlfn.ORG.OPENOFFICE. prefix and namespace when saved to OOXML. Change-Id: Ie5d4eb14b1ec958f9ebec5f149d0d1d7b4dd644e
2016-07-14save ERRORTYPE as _xlfn.ORG.OPENOFFICE.ERRORTYPE to OOXMLEike Rathke1-1/+1
Was wrongly saved as ERRORTYPE without _xlfn. prefix and namespace. Be able to still read ERRORTYPE. Change-Id: Ia028fe06d930f60b4260adf589ee3190b90ea099
2016-07-04remove comphelper::string::removeNoel Grandin1-1/+1
and replace it with OUString/OString::replaceAll Change-Id: I37b1c3b51251dfd9d749d6f1060c75b3a93d7f1a Reviewed-on: https://gerrit.libreoffice.org/26850 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Noel Grandin <noelgrandin@gmail.com>
2016-06-27add an isPODF() block to ScCompiler::IsOpCode(), tdf#100641 relatedEike Rathke1-0/+3
... as we can't rename RID_STRLIST_FUNCTION_NAMES_ENGLISH names. Should we need yet another resource block to differentiate between PODF/API names and actual always available English names? Ugly but maybe. A much better approach would be if Text[en-US] would be always available, additionally to the current localized resource. Change-Id: If8eaf18643f4e24c811149c52efff1097a3c1596
2016-06-27rename *effective to *effect, tdf#100641 relatedEike Rathke2-5/+5
... to unify naming. Change-Id: I0964822d53eafd69ea4ed0656dfdfcb3f5bfd561
2016-06-27tdf#100641 change UI name of EFFECTIVE to EFFECTEike Rathke1-1/+1
... to be the same as in other implementations and ODFF and OOXML. Change-Id: I754283b97e91c5e0f992d878096cf964a1244e04
2016-06-27correct OOXML function name is EFFECT instead of EFFECTIVEEike Rathke1-1/+1
Change-Id: Ieb7484afe210e378efd43ba3a181cd90d29619b9
2016-06-22remove unnecessary whitespaceMarkus Mohrhard1-1/+1
Change-Id: Ia9c9accf3c5509393c3e09692b6a7eae756907f9
2016-06-21tdf#42949: clean up includes in include/formula with iwyuJorenz Paragas5-0/+6
Change-Id: Ieb601d98be80aeb2239d4f0a330d90e63f1abc43 Reviewed-on: https://gerrit.libreoffice.org/26398 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Noel Grandin <noelgrandin@gmail.com>
2016-06-15Move accessibility relations to .ui files, Part 9: tdf#87026Muhammet Kara2-6/+10
By removing unnecessary variables/strings/function calls, and making proper changes in the related .ui files. Change-Id: I52e3f2a16519aee13b06f0efc6beb3385bcb0f1c Reviewed-on: https://gerrit.libreoffice.org/26066 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Katarina Behrens <Katarina.Behrens@cib.de>
2016-06-14explicit svl::SharedString(const OUString&) ctorEike Rathke1-2/+2
... to prevent accidental surprises. Not interned shared strings constructed from OUString have mpDataIgnoreCase=nullptr so can't be used for case insensitive comparison. Change-Id: I03323354298a73e93b18d2796ec447c072fdefa5
2016-06-10assert on FormulaToken::GetDouble() virtual dummyEike Rathke1-1/+2
Change-Id: Ic31c2b943dcc6dfdaaefe3daa120c91cf29ce0e7
2016-06-10check for svDouble when stripping DCOUNT/A argument, tdf#70806 follow-upEike Rathke1-1/+2
Change-Id: Ic7897b5240f9f3f66eb71485ef9eed4fa8ce87e1
2016-06-09Fix ambiguous callsStephan Bergmann1-3/+3
Change-Id: Ia115185b615f86a49004133e00211c197b61db7b
2016-06-08assert on "forgot to add a jump" for OpCodeEike Rathke1-3/+6
Change-Id: I6c430b8a4079cd0d74e5c9e71a3f7b5b638d4ef5
2016-06-08introduce FormulaTypedDoubleToken to carry type information of a doubleEike Rathke1-0/+26
Change-Id: I88b4964ca95eefa41d415ed66fc106c834a686b6
2016-06-06remove unused constants in HRC filesNoel Grandin6-37/+0
Change-Id: Ia034fb16ce75caeb69fd746d4a602cd5fcfef6d1 Reviewed-on: https://gerrit.libreoffice.org/25817 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Noel Grandin <noelgrandin@gmail.com>
2016-05-30cid#1362174, 1362177: USE_AFTER_FREE+resource leak due to copypastaJulien Nabet1-1/+1
Change-Id: Icd903335fdef3921781e2f16e98a0e10bda31e3f Reviewed-on: https://gerrit.libreoffice.org/25641 Reviewed-by: Markus Mohrhard <markus.mohrhard@googlemail.com> Tested-by: Markus Mohrhard <markus.mohrhard@googlemail.com>
2016-05-27strip 0 argument only if not part of an expression, tdf#70806Eike Rathke1-1/+10
Change-Id: Ia1f986a594194a1c564d815bbe2faa987eea971a
2016-05-27omit DCOUNT or DCOUNTA 2nd argument if 0 when writing ODFF or OOXML, tdf#70806Eike Rathke1-6/+44
Change-Id: I2833a1005c6941e66a09172b337e23b0bf7f2002
2016-05-26loplugin:unusedmethodsNoel Grandin1-51/+0
Change-Id: Ib36bc0e87d00abb638cbfec511cd13b6179eabda Reviewed-on: https://gerrit.libreoffice.org/25431 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Noel Grandin <noelgrandin@gmail.com>
2016-05-25(nearly) nothing uses GetUniqueId anymore, so remove it.Caolán McNamara3-96/+30
The odd one out is the usage in Formula, which attempts to restore focus to a particular window identified by an unique id. In this case restore focus by keeping a VclPtr to the desired window. Change-Id: I1dc335325c109d75745c6bba2e12662e6ae50638
2016-05-20clang-tidy misc-assign-operator-signatureNoel Grandin1-1/+1
Change-Id: I2953a88d9e2f5923732865ef17615d5928ac5f5f Reviewed-on: https://gerrit.libreoffice.org/25154 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Noel Grandin <noelgrandin@gmail.com>
2016-05-19clang-tidy modernize-make-uniqueNoel Grandin1-1/+2
Change-Id: I550bb69ddcef69906027516ccde62cf8e87c295b Reviewed-on: https://gerrit.libreoffice.org/25138 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Noel Grandin <noelgrandin@gmail.com>
2016-05-18update unusedmethods plugin to deal with constructorsNoel Grandin2-18/+1
and fix the operator< implementations in some of the other plugins too. Change-Id: Ie5631e0cdc8d2a994ad2af2533cdb558a6cfc035 Reviewed-on: https://gerrit.libreoffice.org/25057 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Noel Grandin <noelgrandin@gmail.com>
2016-05-04tdf#97831 [part] Add Excel 2016 functions to CalcWinfried Donkers1-0/+14
Functions MINIFS and MAXIFS Change-Id: I4bd2e8b82f8377af81f4373d0c33ac286588b8df Reviewed-on: https://gerrit.libreoffice.org/24619 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Eike Rathke <erack@redhat.com> Tested-by: Eike Rathke <erack@redhat.com>
2016-05-03tdf#97831 [part] Add Excel 2016 functions to CalcWinfried Donkers1-0/+14
Functions IFS and SWITCH. Change-Id: Ic43d42a933bcac883e9aa2213dd4ddeddf45abf0 Reviewed-on: https://gerrit.libreoffice.org/24424 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Eike Rathke <erack@redhat.com> Tested-by: Eike Rathke <erack@redhat.com>
2016-05-02check presence of token, tdf#96426 follow-upEike Rathke1-0/+4
Change-Id: I4c368dfd113b02d208013b4ba79dff606769a150